summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cunit/cunit-2.1.ebuild')
-rw-r--r--dev-util/cunit/cunit-2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/cunit/cunit-2.1.ebuild b/dev-util/cunit/cunit-2.1.ebuild
new file mode 100644
index 000000000000..2424312c10da
--- /dev/null
+++ b/dev-util/cunit/cunit-2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/cunit-2.1.ebuild,v 1.1 2008/05/04 03:22:38 jmglov Exp $
+
+inherit eutils autotools
+
+MY_PN='CUnit'
+MY_PV="${PV}-0"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="CUnit - C Unit Test Framework"
+SRC_URI="mirror://sourceforge/cunit/${MY_P}-src.tar.gz"
+HOMEPAGE="http://cunit.sourceforge.net"
+
+DEPEND="virtual/libc"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ eautoreconf
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+ dodoc AUTHORS INSTALL NEWS README ChangeLog
+}