summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gob/gob-1.0.12.ebuild')
-rw-r--r--dev-util/gob/gob-1.0.12.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/gob/gob-1.0.12.ebuild b/dev-util/gob/gob-1.0.12.ebuild
new file mode 100644
index 000000000000..fd43e0a3ba15
--- /dev/null
+++ b/dev-util/gob/gob-1.0.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gob/gob-1.0.12.ebuild,v 1.1 2002/03/27 05:45:40 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GOB is a preprocessor for making GTK+ objects with inline C code"
+SRC_URI="http://ftp.5z.com/pub/gob/${P}.tar.gz"
+HOMEPAGE="http://www.5z.com/jirka/gob.html"
+
+RDEPEND=">=dev-libs/glib-1.2.10"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ assert
+
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}