summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mono-debugger/files/mono-debugger-2.6-system-libedit.patch')
-rw-r--r--dev-util/mono-debugger/files/mono-debugger-2.6-system-libedit.patch91
1 files changed, 0 insertions, 91 deletions
diff --git a/dev-util/mono-debugger/files/mono-debugger-2.6-system-libedit.patch b/dev-util/mono-debugger/files/mono-debugger-2.6-system-libedit.patch
deleted file mode 100644
index f7bdc22bd81a..000000000000
--- a/dev-util/mono-debugger/files/mono-debugger-2.6-system-libedit.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From a857a6fb50605d6f3dddf814081dbbff59d64ba7 Mon Sep 17 00:00:00 2001
-From: Priit Laes <plaes@plaes.org>
-Date: Sun, 21 Feb 2010 14:01:49 +0200
-Subject: [PATCH 1/3] Use system-wide libedit library when requested.
-
----
- configure.in | 15 ++++++++++++++-
- frontend/libedit/Makefile.am | 11 +++++++++--
- frontend/libedit/mono-debugger-readline.h | 10 +++++++++-
- 3 files changed, 32 insertions(+), 4 deletions(-)
-
-diff --git a/configure.in b/configure.in
-index 256afa9..e8ec185 100644
---- a/configure.in
-+++ b/configure.in
-@@ -262,7 +262,20 @@ AC_HEADER_DIRENT
- AC_CHECK_FUNCS(fcntl getpagesize setitimer sysconf fdopen getuid getgid)
- AC_CHECK_FUNCS(strlcpy strlcat fgetln)
-
--CHECK_READLINE
-+AC_ARG_WITH([system-libedit],
-+ AS_HELP_STRING([--with-system-libedit], [Use the system copy of libedit.]))
-+
-+AS_IF([test "x$with_system_libedit" = "xyes"],
-+ [
-+ AC_CHECK_HEADERS([editline/readline.h libedit/readline.h], [found_libedit_header=yes; break;])
-+ AS_IF([test "$found_libedit_header" != "yes"], [AC_MSG_ERROR([Missing libedit/readline.h header])])
-+ AC_CHECK_LIB([edit], [el_init], [:], [AC_MSG_ERROR([Missing libedit library])])
-+ ], [
-+ CHECK_READLINE
-+ ])
-+
-+AM_CONDITIONAL([SYSTEM_LIBEDIT], [test "x$with_system_libedit" = "xyes"])
-+
-
- min_mono_version=72
- symfile_major_version=50
-diff --git a/frontend/libedit/Makefile.am b/frontend/libedit/Makefile.am
-index 9e03757..100cb88 100644
---- a/frontend/libedit/Makefile.am
-+++ b/frontend/libedit/Makefile.am
-@@ -1,14 +1,21 @@
- lib_LTLIBRARIES = libmonodebuggerreadline.la
-
- libmonodebuggerreadline_la_SOURCES = \
-- mono-debugger-readline.c mono-debugger-readline.h readline.c readline.h \
-+ mono-debugger-readline.c mono-debugger-readline.h
-+
-+if SYSTEM_LIBEDIT
-+libedit_libs = -ledit
-+else
-+libedit_libs = @READLINE_DEPLIBS@
-+libmonodebuggerreadline_la_SOURCES += readline.c readline.h \
- chared.c common.c el.c emacs.c fcns.c help.c hist.c history.c key.c map.c \
- parse.c prompt.c read.c refresh.c search.c sig.c term.c tty.c vi.c vis.c unvis.c \
- strlcpy.c strlcat.c chared.h common.h el.h emacs.h fcns.h help.h histedit.h hist.h \
- key.h map.h parse.h prompt.h read.h refresh.h search.h sig.h sys.h term.h tty.h \
- vi.h vis.h el_term.h filecomplete.h tokenizer.c filecomplete.c
-+endif
-
--libmonodebuggerreadline_la_LIBADD = @BASE_DEPENDENCIES_LIBS@ @READLINE_DEPLIBS@
-+libmonodebuggerreadline_la_LIBADD = @BASE_DEPENDENCIES_LIBS@ $(libedit_libs)
- if PLATFORM_X86_DARWIN
- libmonodebuggerreadline_la_LDFLAGS = -no-undefined -shared -Wl
- else
-diff --git a/frontend/libedit/mono-debugger-readline.h b/frontend/libedit/mono-debugger-readline.h
-index c547c75..1a854cc 100644
---- a/frontend/libedit/mono-debugger-readline.h
-+++ b/frontend/libedit/mono-debugger-readline.h
-@@ -1,9 +1,17 @@
- #ifndef __MONO_DEBUGGER_READLINE_H__
- #define __MONO_DEBUGGER_READLINE_H__
-
-+#include <config.h>
-+
- #include <glib.h>
- #include <stdio.h>
--#include <readline.h>
-+#if defined(HAVE_LIBEDIT_READLINE_H)
-+# include <libedit/readline.h>
-+#elif defined(HAVE_LIBEDIT_READLINE_H)
-+# include <libedit/readline.h>
-+#else
-+# include "readline.h"
-+#endif
-
- G_BEGIN_DECLS
-
---
-1.7.0
-