summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/monodevelop')
-rw-r--r--dev-util/monodevelop/ChangeLog12
-rw-r--r--dev-util/monodevelop/files/monodevelop-0.18.1-libstetic.patch28
-rw-r--r--dev-util/monodevelop/files/monodevelop-0.19-exuberant-ctags.patch40
-rw-r--r--dev-util/monodevelop/monodevelop-0.19.ebuild73
4 files changed, 151 insertions, 2 deletions
diff --git a/dev-util/monodevelop/ChangeLog b/dev-util/monodevelop/ChangeLog
index fa69bca4bdfe..eb6d92e1e666 100644
--- a/dev-util/monodevelop/ChangeLog
+++ b/dev-util/monodevelop/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/monodevelop
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monodevelop/ChangeLog,v 1.54 2007/12/31 03:29:35 jurek Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodevelop/ChangeLog,v 1.55 2008/03/02 07:19:50 compnerd Exp $
+
+*monodevelop-0.19 (02 Mar 2008)
+
+ 02 Mar 2008; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/monodevelop-0.18.1-libstetic.patch,
+ +files/monodevelop-0.19-exuberant-ctags.patch, +monodevelop-0.19.ebuild:
+ Version bump from upstream, patch from Ed Catmur <ed@catmur.co.uk> for
+ parallel builds
*monodevelop-0.18.1 (31 Dec 2007)
diff --git a/dev-util/monodevelop/files/monodevelop-0.18.1-libstetic.patch b/dev-util/monodevelop/files/monodevelop-0.18.1-libstetic.patch
new file mode 100644
index 000000000000..4c3150a5e717
--- /dev/null
+++ b/dev-util/monodevelop/files/monodevelop-0.18.1-libstetic.patch
@@ -0,0 +1,28 @@
+--- src/addins/MonoDevelop.GtkCore/lib/Makefile.am 2007/12/27 13:17:42 1.1
++++ src/addins/MonoDevelop.GtkCore/lib/Makefile.am 2007/12/27 13:21:57
+@@ -25,9 +25,11 @@ libstetic_REFERENCES := $(shell sh $(EXT
+ libstetic_DATAFILES := $(shell sh $(EXTRACT_VARS) $(libstetic_MAKEFILE) "libstetic_dll_datafiles")
+ libstetic_DIST := $(addprefix $(libstetic_DIR)/,$(libstetic_DATAFILES)) $(libstetic_MAKEFILE) $(libstetic_RESOURCES) $(libstetic_SOURCES)
+
+-$(libstetic) $(libstetic).mdb: $(libstetic_SOURCES) $(libstetic_RESOURCES) $(libstetic_DATAFILES_BUILD)
++$(libstetic): $(libstetic_SOURCES) $(libstetic_RESOURCES) $(libstetic_DATAFILES_BUILD)
+ mkdir -p $(BUILD_DIR)
+ $(MCS) $(libstetic_FLAGS) -out:$@ $(libstetic_SOURCES) $(libstetic_REFERENCES) $(libstetic_RESOURCES:%=-resource:%)
++$(libstetic).mdb: $(libstetic)
++ true
+
+ libstetic_DATAFILES_BUILD = $(addprefix $(BUILD_DIR)/, $(libstetic_DATAFILES))
+
+@@ -63,9 +65,11 @@ libsteticui_REFERENCES = \
+ -r:System.Runtime.Remoting \
+ -r:System.Xml
+
+-$(libsteticui) $(libsteticui).mdb: $(libsteticui_SOURCES) $(libsteticui_RESOURCES) $(libsteticui_DATAFILES_BUILD)
++$(libsteticui): $(libsteticui_SOURCES) $(libsteticui_RESOURCES) $(libsteticui_DATAFILES_BUILD) $(libstetic)
+ mkdir -p $(BUILD_DIR)
+ $(MCS) $(libsteticui_FLAGS) -out:$@ $(libsteticui_SOURCES) $(libsteticui_REFERENCES) $(libsteticui_RESOURCES:%=-resource:%)
++$(libsteticui).mdb: $(libsteticui)
++ true
+
+ libsteticui_DATAFILES_BUILD = $(addprefix $(BUILD_DIR)/, $(libsteticui_DATAFILES))
+
diff --git a/dev-util/monodevelop/files/monodevelop-0.19-exuberant-ctags.patch b/dev-util/monodevelop/files/monodevelop-0.19-exuberant-ctags.patch
new file mode 100644
index 000000000000..9e3937e11837
--- /dev/null
+++ b/dev-util/monodevelop/files/monodevelop-0.19-exuberant-ctags.patch
@@ -0,0 +1,40 @@
+--- src/addins/CBinding/Navigation/ProjectNodeBuilderExtension.cs 2007-12-20 20:05:02.000000000 +0100
++++ src/addins/CBinding/Navigation/ProjectNodeBuilderExtension.cs 2007-12-27 23:27:41.000000000 +0100
+@@ -96,7 +96,7 @@
+ check_ctags = true;
+
+ try {
+- ProcessWrapper p = Runtime.ProcessService.StartProcess ("ctags", "--version", null, null);
++ ProcessWrapper p = Runtime.ProcessService.StartProcess ("exuberant-ctags", "--version", null, null);
+ p.WaitForOutput ();
+ have_ctags = true;
+ } catch {
+--- src/addins/CBinding/Parser/TagDatabaseManager.cs 2008-03-01 15:03:07.000000000 -0800
++++ src/addins/CBinding/Parser/TagDatabaseManager.cs 2008-03-01 15:03:53.000000000 -0800
+@@ -77,7 +77,7 @@
+ if (!checkedCtagsInstalled) {
+ checkedCtagsInstalled = true;
+ try {
+- Runtime.ProcessService.StartProcess ("ctags", "--version", null, null).WaitForOutput ();
++ Runtime.ProcessService.StartProcess ("exuberant-ctags", "--version", null, null).WaitForOutput ();
+ } catch {
+ LoggingService.LogWarning ("Cannot update C/C++ tags database because exuberant ctags is not installed.");
+ return false;
+@@ -183,7 +183,7 @@
+ ProcessWrapper p;
+
+ try {
+- p = Runtime.ProcessService.StartProcess ("ctags", ctags_options, null, null);
++ p = Runtime.ProcessService.StartProcess ("exuberant-ctags", ctags_options, null, null);
+ p.WaitForExit ();
+ } catch (Exception ex) {
+ throw new IOException ("Could not create tags database (You must have exuberant ctags installed).", ex);
+@@ -259,7 +259,7 @@
+ ProcessWrapper p;
+
+ try {
+- p = Runtime.ProcessService.StartProcess ("ctags", ctags_options, null, null);
++ p = Runtime.ProcessService.StartProcess ("exuberant-ctags", ctags_options, null, null);
+ p.WaitForExit (10000); //If no return detected in 10s, kill anyway
+ } catch (Exception ex) {
+ throw new IOException ("Could not create tags database (You must have exuberant ctags installed).", ex);
diff --git a/dev-util/monodevelop/monodevelop-0.19.ebuild b/dev-util/monodevelop/monodevelop-0.19.ebuild
new file mode 100644
index 000000000000..7496495f2fa2
--- /dev/null
+++ b/dev-util/monodevelop/monodevelop-0.19.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodevelop/monodevelop-0.19.ebuild,v 1.1 2008/03/02 07:19:50 compnerd Exp $
+
+inherit autotools eutils fdo-mime mono multilib
+
+DESCRIPTION="Integrated Development Environemnt for .NET"
+HOMEPAGE="http://www.monodevelop.com/"
+SRC_URI="http://www.go-mono.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aspnet cxx subversion"
+
+RDEPEND=">=dev-lang/mono-1.1.10
+ >=dev-util/monodoc-1.0
+ >=dev-dotnet/mono-addins-0.3
+ >=dev-dotnet/gtk-sharp-2.8
+ >=dev-dotnet/glade-sharp-2.8
+ >=dev-dotnet/gnome-sharp-2.8
+ >=dev-dotnet/gnomevfs-sharp-2.8
+ >=dev-dotnet/gconf-sharp-2.8
+ >=dev-dotnet/gtksourceview-sharp-0.10
+ || (
+ www-client/mozilla-firefox
+ www-client/mozilla-firefox-bin
+ www-client/seamonkey
+ net-libs/xulrunner
+ )
+ aspnet? ( >=dev-dotnet/xsp-1.2.1 )
+ subversion? ( dev-util/subversion )
+ cxx? ( dev-util/ctags )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ x11-misc/shared-mime-info
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-0.18.1-configure.patch"
+ epatch "${FILESDIR}/${PN}-0.18.1-libstetic.patch"
+ epatch "${FILESDIR}/${PN}-0.19-exuberant-ctags.patch"
+
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_compile() {
+ econf --disable-update-mimedb \
+ --disable-update-desktopdb \
+ --enable-monoextensions \
+ --enable-versioncontrol \
+ $(use_enable aspnet) \
+ $(use_enable subversion) \
+ $(use_enable cxx c) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}