summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/patchutils/patchutils-0.3.0.ebuild')
-rw-r--r--dev-util/patchutils/patchutils-0.3.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/patchutils/patchutils-0.3.0.ebuild b/dev-util/patchutils/patchutils-0.3.0.ebuild
new file mode 100644
index 000000000000..5a6e217d4ad6
--- /dev/null
+++ b/dev-util/patchutils/patchutils-0.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/patchutils/patchutils-0.3.0.ebuild,v 1.1 2008/11/12 23:45:00 flameeyes Exp $
+
+WANT_AUTOMAKE=1.8
+inherit autotools
+
+DESCRIPTION="A collection of tools that operate on patch files"
+HOMEPAGE="http://cyberelk.net/tim/patchutils/"
+SRC_URI="http://cyberelk.net/tim/data/patchutils/stable/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=""
+# The testsuite makes use of gendiff(1) that comes from rpm, thus if
+# the user wants to run tests, it should install that too.
+DEPEND="test? ( app-arch/rpm )"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO || die "dodoc failed"
+}