summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/glaxium/glaxium-0.5.ebuild')
-rw-r--r--games-action/glaxium/glaxium-0.5.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/games-action/glaxium/glaxium-0.5.ebuild b/games-action/glaxium/glaxium-0.5.ebuild
index b892341815c7..04e90006221c 100644
--- a/games-action/glaxium/glaxium-0.5.ebuild
+++ b/games-action/glaxium/glaxium-0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/glaxium-0.5.ebuild,v 1.13 2006/01/28 21:19:10 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/glaxium-0.5.ebuild,v 1.14 2006/04/02 11:14:32 tupone Exp $
inherit eutils flag-o-matic toolchain-funcs games
@@ -29,14 +29,10 @@ S="${WORKDIR}/${PN}_${PV}"
src_unpack() {
unpack ${A}
cd ${S}
- $(tc-getCXX) ${FILESDIR}/glx-test.c >& /dev/null
- if [ $? -ne 0 ] ; then
- epatch "${FILESDIR}/${PV}-glx.patch"
- append-flags -DGL_GLEXT_LEGACY
- fi
has_version '>=media-video/nvidia-glx-1.0.5328' \
- && epatch "${FILESDIR}/${PV}-another-glx.patch"
- epatch "${FILESDIR}/${PV}-rc.patch"
+ && epatch "${FILESDIR}/${P}-glx.patch"
+ epatch "${FILESDIR}/${PV}-rc.patch" \
+ "${FILESDIR}/${P}-gcc41.patch"
}
src_compile() {