summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/violetland/violetland-0.4.3.ebuild')
-rw-r--r--games-action/violetland/violetland-0.4.3.ebuild23
1 files changed, 19 insertions, 4 deletions
diff --git a/games-action/violetland/violetland-0.4.3.ebuild b/games-action/violetland/violetland-0.4.3.ebuild
index 410410230af7..00a44d27d43a 100644
--- a/games-action/violetland/violetland-0.4.3.ebuild
+++ b/games-action/violetland/violetland-0.4.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.4.3.ebuild,v 1.3 2011/12/07 07:41:04 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.4.3.ebuild,v 1.4 2012/08/29 04:23:28 mr_bones_ Exp $
EAPI=2
-inherit eutils cmake-utils games
+inherit eutils multilib toolchain-funcs flag-o-matic cmake-utils games
DESCRIPTION="Help a girl by name of Violet to struggle with hordes of monsters."
HOMEPAGE="http://code.google.com/p/violetland/"
@@ -18,7 +18,8 @@ RDEPEND="media-libs/libsdl[audio,video]
media-libs/sdl-image[png]
media-libs/sdl-mixer[vorbis]
media-libs/sdl-ttf
- dev-libs/boost
+ <dev-libs/boost-1.50
+ >=dev-libs/boost-1.37
virtual/opengl
virtual/glu"
DEPEND="${RDEPEND}
@@ -31,6 +32,20 @@ src_prepare() {
-e "/README_EN.TXT/d" \
-e "/README_RU.TXT/d" \
CMakeLists.txt || die "sed failed"
+ # how do I hate boost? Let me count the ways...
+ local boost_ver=$(best_version "<dev-libs/boost-1.50")
+
+ boost_ver=${boost_ver/*boost-/}
+ boost_ver=${boost_ver%.*}
+ boost_ver=${boost_ver/./_}
+
+ einfo "Using boost version ${boost_ver}"
+ append-cxxflags \
+ -I/usr/include/boost-${boost_ver}
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-${boost_ver}
+ export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
+ export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
}
src_configure() {