summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/gcube/gcube-0.3.ebuild')
-rw-r--r--games-emulation/gcube/gcube-0.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-emulation/gcube/gcube-0.3.ebuild b/games-emulation/gcube/gcube-0.3.ebuild
new file mode 100644
index 000000000000..38519c8f653d
--- /dev/null
+++ b/games-emulation/gcube/gcube-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gcube/gcube-0.3.ebuild,v 1.1 2004/12/26 22:37:27 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Gamecube emulator"
+HOMEPAGE="http://gcube.exemu.net/"
+SRC_URI="http://gcube.exemu.net/downloads/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/libsdl
+ sys-libs/ncurses
+ sys-libs/zlib"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i '/^CFLAGS=-g/d' Makefile.rules
+}
+
+src_install() {
+ dogamesbin gcmap gcube || die "gcube"
+ local x
+ for x in bin2dol isopack tplx ; do
+ newgamesbin ${x} ${PN}-${x} || die "${x} failed"
+ done
+ dodoc ChangeLog README
+ prepgamesdirs
+}