summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/doomlegacy/files')
-rw-r--r--games-fps/doomlegacy/files/1.42-errno.patch33
-rw-r--r--games-fps/doomlegacy/files/1.42-makefile.patch108
-rw-r--r--games-fps/doomlegacy/files/1.42-sdl-gentoo-paths.patch15
-rw-r--r--games-fps/doomlegacy/files/digest-doomlegacy-1.422
4 files changed, 158 insertions, 0 deletions
diff --git a/games-fps/doomlegacy/files/1.42-errno.patch b/games-fps/doomlegacy/files/1.42-errno.patch
new file mode 100644
index 000000000000..ff62d004353e
--- /dev/null
+++ b/games-fps/doomlegacy/files/1.42-errno.patch
@@ -0,0 +1,33 @@
+diff -ur doomlegacy_142_src.orig/linux_x/i_sound.c doomlegacy_142_src/linux_x/i_sound.c
+--- doomlegacy_142_src.orig/linux_x/i_sound.c 2004-05-09 11:51:20.908123440 +0200
++++ doomlegacy_142_src/linux_x/i_sound.c 2004-05-09 11:40:26.257645440 +0200
+@@ -262,7 +262,6 @@
+ void myioctl(int fd, int command, int *arg)
+ {
+ int rc;
+- extern int errno;
+
+ rc = ioctl(fd, command, arg);
+ if (rc < 0)
+diff -ur doomlegacy_142_src.orig/linux_x/i_video_xshm.c doomlegacy_142_src/linux_x/i_video_xshm.c
+--- doomlegacy_142_src.orig/linux_x/i_video_xshm.c 2004-05-09 11:51:20.909123288 +0200
++++ doomlegacy_142_src/linux_x/i_video_xshm.c 2004-05-09 11:40:15.969209520 +0200
+@@ -1401,7 +1401,6 @@
+ id = shmget((key_t)key, size, IPC_CREAT|0777);
+ if (id==-1)
+ {
+- extern int errno;
+ fprintf(stderr, "errno=%d\n", errno);
+ I_Error("Could not get any shared memory");
+ }
+diff -ur doomlegacy_142_src.orig/linux_x/sndserv/linux.c doomlegacy_142_src/linux_x/sndserv/linux.c
+--- doomlegacy_142_src.orig/linux_x/sndserv/linux.c 2004-05-09 11:51:20.910123136 +0200
++++ doomlegacy_142_src/linux_x/sndserv/linux.c 2004-05-09 11:39:50.198127320 +0200
+@@ -74,7 +74,6 @@
+ int* arg )
+ {
+ int rc;
+- extern int errno;
+
+ rc = ioctl(fd, command, arg);
+ if (rc < 0)
diff --git a/games-fps/doomlegacy/files/1.42-makefile.patch b/games-fps/doomlegacy/files/1.42-makefile.patch
new file mode 100644
index 000000000000..c6905cdb5588
--- /dev/null
+++ b/games-fps/doomlegacy/files/1.42-makefile.patch
@@ -0,0 +1,108 @@
+diff -ur doomlegacy_142_src.orig/linux_x/musserv/Makefile.linux doomlegacy_142_src/linux_x/musserv/Makefile.linux
+--- doomlegacy_142_src.orig/linux_x/musserv/Makefile.linux 2004-05-09 11:51:20.907123592 +0200
++++ doomlegacy_142_src/linux_x/musserv/Makefile.linux 2004-05-09 11:59:20.982141096 +0200
+@@ -3,7 +3,7 @@
+ #
+
+ CC = gcc
+-CFLAGS = -I. -Wall -O2 -m486
++CFLAGS = -I. -Wall $(EXTRAOPTS)
+ LDFLAGS =
+ #LDFLAGS = -static
+
+diff -ur doomlegacy_142_src.orig/linux_x/sndserv/Makefile doomlegacy_142_src/linux_x/sndserv/Makefile
+--- doomlegacy_142_src.orig/linux_x/sndserv/Makefile 2004-05-09 11:51:20.909123288 +0200
++++ doomlegacy_142_src/linux_x/sndserv/Makefile 2004-05-09 11:59:20.983140944 +0200
+@@ -27,7 +27,7 @@
+ #
+
+ CC=gcc
+-CFLAGS=-O2 -m486 -Wall -DNORMALUNIX -DLINUX
++CFLAGS=$(EXTRAOPTS) -Wall -DNORMALUNIX -DLINUX
+ ifdef FREEBSD
+ CFLAGS:=${CFLAGS} -DFREEBSD
+ endif
+diff -ur doomlegacy_142_src.orig/makefile doomlegacy_142_src/makefile
+--- doomlegacy_142_src.orig/makefile 2004-05-09 11:51:20.934119488 +0200
++++ doomlegacy_142_src/makefile 2004-05-09 11:59:20.982141096 +0200
+@@ -533,11 +533,11 @@
+
+ ifndef SOLARIS
+ ifdef GCC30
+- M5=-march=pentium
+- M4=-march=486
++ M5=
++ M4=
+ else
+- M5=-mpentium
+- M4=-m486
++ M5=
++ M4=
+ endif
+ endif
+
+@@ -547,7 +547,7 @@
+ ifdef PGCC
+ CFLAGS = -g -pg -DPARANOIA -fwritable-strings $(OPTS)
+ else
+- CFLAGS = -g -pg $(M4) -O3 -ffast-math -fwritable-strings $(OPTS)
++ CFLAGS = -g -pg $(M4) $(OPTS) $(EXTRAOPTS)
+ endif
+ LDFLAGS = -g -pg -L/usr/X11R6/lib
+ else
+@@ -555,13 +555,13 @@
+
+ # build a normal optimised version
+ ifdef PGCC
+- CFLAGS = $(OPTS) $(M5) -O6 -ffast-math -fomit-frame-pointer -fwritable-strings
++ CFLAGS = $(OPTS) $(M5) -fwritable-strings $(EXTRAOPTS)
+ # -fgcse -fcse-follow-jumps -fcse-skip-blocks -frerun-cse-after-loop -ffunction-cse \
+ # -fexpensive-optimizations -fforce-mem -fstrength-reduce -fthread-jumps \
+ # -fregmove -fschedule-insns -fschedule-insns2 -fmove-all-movables \
+ # -fcaller-saves -finline-functions -mieee-fp -mfp-ret-in-387 -m80387 -mhard-float -finline
+ else
+- CFLAGS = $(M4) -O3 -ffast-math -fomit-frame-pointer -fwritable-strings $(OPTS)
++ CFLAGS = $(M4) -fwritable-strings $(OPTS) $(EXTRAOPTS)
+ endif
+ endif
+
+@@ -735,7 +735,7 @@
+
+ #dll
+ dll : $(O)/r_opengl.o $(O)/ogl_x11.o
+- $(CC) $(M5) -O6 -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
++ $(CC) $(M5) -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
+
+ musserv:
+ @mkdir -p $(MUSSERV)/linux
+@@ -749,7 +749,7 @@
+
+ ifdef LINUX
+ $(O)/r_opengl.o: hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
+- $(CC) $(M5) -O6 -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
++ $(CC) $(M5) -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
+ endif
+
+ ifdef SDL
+@@ -763,7 +763,7 @@
+ $(CC) $(CFLAGS) $(LDFLAGS) $(WFLAGS) -I/usr/X11R6/include -c $< -o $@
+ else #FBSD_SDL
+ $(O)/r_opengl.o: hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
+- $(CC) $(M5) -O6 -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
++ $(CC) $(M5) -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
+ endif #FBSD_SDL
+ endif #FREEBSD
+
+@@ -774,10 +774,10 @@
+
+ ifndef FREEBSD
+ $(O)/ogl_x11.o: hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
+- $(CC) $(M5) -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
++ $(CC) $(M5) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
+ else
+ $(O)/ogl_x11.o: hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
+- $(CC) $(M5) -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
++ $(CC) $(M5) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
+ endif
+
+
diff --git a/games-fps/doomlegacy/files/1.42-sdl-gentoo-paths.patch b/games-fps/doomlegacy/files/1.42-sdl-gentoo-paths.patch
new file mode 100644
index 000000000000..995e557b74fc
--- /dev/null
+++ b/games-fps/doomlegacy/files/1.42-sdl-gentoo-paths.patch
@@ -0,0 +1,15 @@
+diff -ur doomlegacy_142_src.orig/sdl/i_system.c doomlegacy_142_src/sdl/i_system.c
+--- doomlegacy_142_src.orig/sdl/i_system.c 2004-05-09 11:51:20.913122680 +0200
++++ doomlegacy_142_src/sdl/i_system.c 2004-05-09 14:54:23.716482784 +0200
+@@ -734,6 +734,11 @@
+
+ void I_LocateWad(void) {
+ // relict from the Linux version
++#ifdef LINUX
++#define WADLOCATION "GENTOO_DATADIR"
++ if(chdir(WADLOCATION))
++ fprintf (stderr, "Error: chdir() " WADLOCATION " failed\n");
++#endif
+ return;
+ }
+
diff --git a/games-fps/doomlegacy/files/digest-doomlegacy-1.42 b/games-fps/doomlegacy/files/digest-doomlegacy-1.42
new file mode 100644
index 000000000000..af8620e8c419
--- /dev/null
+++ b/games-fps/doomlegacy/files/digest-doomlegacy-1.42
@@ -0,0 +1,2 @@
+MD5 62f5cdad464463038d568a53b13c22f7 legacy_142_src.tar.gz 1687954
+MD5 7910062a0c722f2a2a83f5ca90c72c90 legacy-1.42.dat.bz2 314469