summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/pingus')
-rw-r--r--games-puzzle/pingus/ChangeLog29
-rw-r--r--games-puzzle/pingus/Manifest5
-rw-r--r--games-puzzle/pingus/files/0.6.0-gcc3.patch110
-rw-r--r--games-puzzle/pingus/files/digest-pingus-0.6.01
-rw-r--r--games-puzzle/pingus/files/digest-pingus-0.6.0-r11
-rw-r--r--games-puzzle/pingus/pingus-0.6.0-r1.ebuild48
-rw-r--r--games-puzzle/pingus/pingus-0.6.0.ebuild33
7 files changed, 227 insertions, 0 deletions
diff --git a/games-puzzle/pingus/ChangeLog b/games-puzzle/pingus/ChangeLog
new file mode 100644
index 000000000000..904890de5c6c
--- /dev/null
+++ b/games-puzzle/pingus/ChangeLog
@@ -0,0 +1,29 @@
+# ChangeLog for app-games/pingus
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.1 2003/09/10 06:36:00 vapier Exp $
+
+*pingus-0.6.0-r1 (16 Jul 2003)
+
+ 10 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ gcc3 patch (add assert.h to a lot of files) #28281.
+
+ 16 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Update to use ClanLib SLOT-ing.
+
+*pingus-0.6.0 (22 Apr 2003)
+
+ 10 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ gcc3 patch (add assert.h to a lot of files) #28281.
+
+ 05 May 2003; Paul de Vrieze <pauldv@gentoo.org> pingus-0.6.0.ebuild:
+ pingus does not configure well with the 0.7 release of clanlib
+
+ 27 Apr 2003; Paul de Vrieze <pauldv@gentoo.org> pingus-0.6.0.ebuild:
+ Marked the ebuild testing as clanlib-0.6.5 is not yet stable. Also fixed the
+ header.
+
+ 22 Apr 2003; Patrick Kursawe <phosphan@gentoo.org> ChangeLog,
+ files/digest-pingus-0.6.0, pingus-0.6.0.ebuild :
+ Initial import. Based on an ebuild submitted by
+ Stuart Bouyer <stuart_bouyer@ybb.ne.jp> after quite some discussion
+ about bug #19454.
diff --git a/games-puzzle/pingus/Manifest b/games-puzzle/pingus/Manifest
new file mode 100644
index 000000000000..d94a345adde7
--- /dev/null
+++ b/games-puzzle/pingus/Manifest
@@ -0,0 +1,5 @@
+MD5 cf74eabf33bb46fc3ed87e741b182c10 files/digest-pingus-0.6.0 66
+MD5 cf74eabf33bb46fc3ed87e741b182c10 files/digest-pingus-0.6.0-r1 66
+MD5 ca45c5e3ac7c9c445f960f86607c3615 ChangeLog 916
+MD5 d74f38c394f6eb68b2b8d81622dcbefc pingus-0.6.0.ebuild 628
+MD5 ac335d50a0de62174a40e4c1b2334d56 pingus-0.6.0-r1.ebuild 932
diff --git a/games-puzzle/pingus/files/0.6.0-gcc3.patch b/games-puzzle/pingus/files/0.6.0-gcc3.patch
new file mode 100644
index 000000000000..73c49513006e
--- /dev/null
+++ b/games-puzzle/pingus/files/0.6.0-gcc3.patch
@@ -0,0 +1,110 @@
+diff -ur -x '*Po' pingus-0.6.0.orig/src/blitter.cxx pingus-0.6.0/src/blitter.cxx
+--- pingus-0.6.0.orig/src/blitter.cxx 2003-09-10 01:01:17.022128512 -0400
++++ pingus-0.6.0/src/blitter.cxx 2003-09-10 01:09:43.097193408 -0400
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <assert.h>
+ #include <config.h>
+ #include <stdio.h>
+ #include "pingus_error.hxx"
+diff -ur -x '*Po' pingus-0.6.0.orig/src/col_map.cxx pingus-0.6.0/src/col_map.cxx
+--- pingus-0.6.0.orig/src/col_map.cxx 2003-09-10 01:01:17.054123648 -0400
++++ pingus-0.6.0/src/col_map.cxx 2003-09-10 01:10:52.076706928 -0400
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <assert.h>
+ #include <iostream>
+ #include <ClanLib/Display/SurfaceProviders/canvas.h>
+ #include "gui/graphic_context.hxx"
+diff -ur -x '*Po' pingus-0.6.0.orig/src/console.cxx pingus-0.6.0/src/console.cxx
+--- pingus-0.6.0.orig/src/console.cxx 2003-09-10 01:01:17.025128056 -0400
++++ pingus-0.6.0/src/console.cxx 2003-09-10 01:11:17.323868776 -0400
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <assert.h>
+ #include <config.h>
+ #include <ClanLib/Display/Display/display.h>
+ #include <ClanLib/Display/Font/font.h>
+diff -ur -x '*Po' pingus-0.6.0.orig/src/demo_recorder.cxx pingus-0.6.0/src/demo_recorder.cxx
+--- pingus-0.6.0.orig/src/demo_recorder.cxx 2003-09-10 01:01:17.049124408 -0400
++++ pingus-0.6.0/src/demo_recorder.cxx 2003-09-10 01:11:50.095886672 -0400
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <assert.h>
+ #include <time.h>
+ #include <iostream>
+ #include "system.hxx"
+diff -ur -x '*Po' pingus-0.6.0.orig/src/editor/generic_property_frame.cxx pingus-0.6.0/src/editor/generic_property_frame.cxx
+--- pingus-0.6.0.orig/src/editor/generic_property_frame.cxx 2003-09-10 01:01:17.028127600 -0400
++++ pingus-0.6.0/src/editor/generic_property_frame.cxx 2003-09-10 01:01:47.907433232 -0400
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <assert.h>
+ #include <iostream>
+ #include <ClanLib/GUI/label.h>
+ #include <ClanLib/GUI/inputbox.h>
+diff -ur -x '*Po' pingus-0.6.0.orig/src/gui/root_gui_manager.cxx pingus-0.6.0/src/gui/root_gui_manager.cxx
+--- pingus-0.6.0.orig/src/gui/root_gui_manager.cxx 2003-09-10 01:01:17.002131552 -0400
++++ pingus-0.6.0/src/gui/root_gui_manager.cxx 2003-09-10 01:04:11.164654824 -0400
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <assert.h>
+ #include "root_gui_manager.hxx"
+ #include "../input/controller.hxx"
+
+diff -ur -x '*Po' pingus-0.6.0.orig/src/pingu_holder.cxx pingus-0.6.0/src/pingu_holder.cxx
+--- pingus-0.6.0.orig/src/pingu_holder.cxx 2003-09-10 01:01:17.054123648 -0400
++++ pingus-0.6.0/src/pingu_holder.cxx 2003-09-10 01:13:48.283919360 -0400
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <assert.h>
+ #include <iostream>
+ #include "pingu_holder.hxx"
+ #include "pingu.hxx"
+diff -ur -x '*Po' pingus-0.6.0.orig/src/savegame_manager.cxx pingus-0.6.0/src/savegame_manager.cxx
+--- pingus-0.6.0.orig/src/savegame_manager.cxx 2003-09-10 01:01:17.035126536 -0400
++++ pingus-0.6.0/src/savegame_manager.cxx 2003-09-10 01:15:43.254441184 -0400
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <assert.h>
+ #include <iostream>
+ #include <fstream>
+ #include "system.hxx"
+diff -ur -x '*Po' pingus-0.6.0.orig/src/worldmap/dot.cxx pingus-0.6.0/src/worldmap/dot.cxx
+--- pingus-0.6.0.orig/src/worldmap/dot.cxx 2003-09-10 01:01:17.036126384 -0400
++++ pingus-0.6.0/src/worldmap/dot.cxx 2003-09-10 01:06:29.392640976 -0400
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <assert.h>
+ #include <iostream>
+ #include "../xml_file_reader.hxx"
+ #include "dot.hxx"
+diff -ur -x '*Po' pingus-0.6.0.orig/src/worldmap/graph.hxx pingus-0.6.0/src/worldmap/graph.hxx
+--- pingus-0.6.0.orig/src/worldmap/graph.hxx 2003-09-10 01:01:17.037126232 -0400
++++ pingus-0.6.0/src/worldmap/graph.hxx 2003-09-10 01:07:31.004274584 -0400
+@@ -20,6 +20,7 @@
+ #ifndef HEADER_GRAPH_HXX
+ #define HEADER_GRAPH_HXX
+
++#include <assert.h>
+ #include <algorithm>
+ #include <vector>
+
diff --git a/games-puzzle/pingus/files/digest-pingus-0.6.0 b/games-puzzle/pingus/files/digest-pingus-0.6.0
new file mode 100644
index 000000000000..2ae1b8a4f4d2
--- /dev/null
+++ b/games-puzzle/pingus/files/digest-pingus-0.6.0
@@ -0,0 +1 @@
+MD5 9cd678272b97dbdb53f42324be31eacd pingus-0.6.0.tar.bz2 9585580
diff --git a/games-puzzle/pingus/files/digest-pingus-0.6.0-r1 b/games-puzzle/pingus/files/digest-pingus-0.6.0-r1
new file mode 100644
index 000000000000..2ae1b8a4f4d2
--- /dev/null
+++ b/games-puzzle/pingus/files/digest-pingus-0.6.0-r1
@@ -0,0 +1 @@
+MD5 9cd678272b97dbdb53f42324be31eacd pingus-0.6.0.tar.bz2 9585580
diff --git a/games-puzzle/pingus/pingus-0.6.0-r1.ebuild b/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..a1e2104f884b
--- /dev/null
+++ b/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.6.0-r1.ebuild,v 1.1 2003/09/10 06:36:00 vapier Exp $
+
+inherit games
+
+DESCRIPTION="free Lemmings clone"
+HOMEPAGE="http://pingus.seul.org/"
+SRC_URI="http://pingus.seul.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=media-libs/hermes-1.3.2-r2
+ =dev-games/clanlib-0.6.5*
+ >=dev-libs/libxml2-2.5.6"
+
+pkg_setup() {
+ clanlib-config 0.6.5
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc3.patch
+}
+
+src_compile() {
+ egamesconf \
+ --with-bindir=${GAMES_BINDIR} \
+ --with-datadir=${GAMES_DATADIR_BASE} \
+ `use_with opengl clanGL` \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ # pos install process ... FIXME
+ mv ${D}/usr/games/{games,bin}
+ cd ${D}/usr/share/games
+ mv locale ../
+ mv games/pingus .
+ rm -rf games
+ # end pos install process
+ prepgamesdirs
+}
diff --git a/games-puzzle/pingus/pingus-0.6.0.ebuild b/games-puzzle/pingus/pingus-0.6.0.ebuild
new file mode 100644
index 000000000000..b200eb785ca6
--- /dev/null
+++ b/games-puzzle/pingus/pingus-0.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.6.0.ebuild,v 1.1 2003/09/10 06:36:00 vapier Exp $
+
+inherit games
+
+DESCRIPTION="free Lemmings clone"
+HOMEPAGE="http://pingus.seul.org/"
+SRC_URI="http://pingus.seul.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=media-libs/hermes-1.3.2-r2
+ =dev-games/clanlib-0.6.5*
+ >=dev-libs/libxml2-2.5.6"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc3.patch
+}
+
+src_compile() {
+ egamesconf || die
+ emake || die
+}
+
+src_install() {
+ einstall bindir=${D}/${GAMES_BINDIR} || die
+ prepgamesdirs
+}