summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike/ivan/ivan-0.50.ebuild')
-rw-r--r--games-roguelike/ivan/ivan-0.50.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/games-roguelike/ivan/ivan-0.50.ebuild b/games-roguelike/ivan/ivan-0.50.ebuild
index 1b71a0c1e870..9afafa061c90 100644
--- a/games-roguelike/ivan/ivan-0.50.ebuild
+++ b/games-roguelike/ivan/ivan-0.50.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ivan-0.50.ebuild,v 1.2 2005/11/27 02:01:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ivan-0.50.ebuild,v 1.3 2006/01/05 05:38:33 mr_bones_ Exp $
-inherit games
+inherit flag-o-matic games
DESCRIPTION="Rogue-like game with SDL graphics"
HOMEPAGE="http://ivan.sourceforge.net/"
@@ -15,6 +15,12 @@ IUSE=""
DEPEND=">=media-libs/libsdl-1.2.0"
+src_compile() {
+ replace-flags -O? -O0 #bug #113627
+ egamesconf || die
+ emake || die "emake failed"
+}
+
src_install() {
egamesinstall || die
dodoc AUTHORS ChangeLog LICENSING NEWS README