summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/freedroidrpg/freedroidrpg-0.10.0.ebuild')
-rw-r--r--games-rpg/freedroidrpg/freedroidrpg-0.10.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-rpg/freedroidrpg/freedroidrpg-0.10.0.ebuild b/games-rpg/freedroidrpg/freedroidrpg-0.10.0.ebuild
new file mode 100644
index 000000000000..4b20c9c98dd5
--- /dev/null
+++ b/games-rpg/freedroidrpg/freedroidrpg-0.10.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/freedroidrpg/freedroidrpg-0.10.0.ebuild,v 1.1 2007/02/06 17:57:47 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="A modification of the classical Freedroid engine into an RPG"
+HOMEPAGE="http://freedroid.sourceforge.net/"
+SRC_URI="mirror://sourceforge/freedroid/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+RDEPEND=">=media-libs/libsdl-1.2.3
+ media-libs/jpeg
+ sys-libs/zlib
+ media-libs/libpng
+ media-libs/sdl-image
+ media-libs/sdl-net
+ media-libs/sdl-mixer
+ media-libs/libogg
+ media-libs/libvorbis
+ x11-libs/libX11
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ x11-libs/libXt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ find sound graphics -type f -print0 | xargs -0 chmod a-x
+}
+
+src_compile() {
+ egamesconf \
+ --disable-editors \
+ $(use_enable opengl) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}/${GAMES_BINDIR}/"{croppy,pngtoico}
+ newicon win32/w32icon2_64x64.png ${PN}.png
+ make_desktop_entry freedroidRPG "Freedroid RPG"
+ prepgamesdirs
+}