summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-server/halflife-modsetup/halflife-modsetup-0.1.1.ebuild')
-rw-r--r--games-server/halflife-modsetup/halflife-modsetup-0.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-server/halflife-modsetup/halflife-modsetup-0.1.1.ebuild b/games-server/halflife-modsetup/halflife-modsetup-0.1.1.ebuild
new file mode 100644
index 000000000000..4b10165ad7c5
--- /dev/null
+++ b/games-server/halflife-modsetup/halflife-modsetup-0.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/halflife-modsetup/halflife-modsetup-0.1.1.ebuild,v 1.1 2003/09/10 05:51:11 vapier Exp $
+
+inherit games
+
+DESCRIPTION="script to assist in setting up your server"
+HOMEPAGE="http://wh0rd.org/"
+SRC_URI="mirror://gentoo/${P}.tbz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND="dev-util/dialog"
+
+src_unpack() {
+ unpack ${A}
+ sed -i \
+ -e "s:GENTOO_HLDIR:${GAMES_PREFIX_OPT}/halflife:" \
+ -e "s:GENTOO_CFGDIR:${GAMES_SYSCONFDIR}/halflife:" \
+ ${S}/halflife-modsetup
+}
+
+src_install() {
+ dogamesbin halflife-modsetup
+ insinto ${GAMES_SYSCONFDIR}/halflife
+ doins modsetup.conf
+ prepgamesdirs
+}