summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/wesnoth/wesnoth-0.7.1.ebuild')
-rw-r--r--games-strategy/wesnoth/wesnoth-0.7.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-strategy/wesnoth/wesnoth-0.7.1.ebuild b/games-strategy/wesnoth/wesnoth-0.7.1.ebuild
new file mode 100644
index 000000000000..ede106dc39f8
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.7.1.ebuild,v 1.1 2004/04/03 23:49:02 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc ~sparc"
+IUSE="server editor tools"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ virtual/x11"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ `use_enable server` \
+ `use_enable editor` \
+ `use_enable tools` \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc MANUAL changelog || die "dodoc failed"
+ prepgamesdirs
+}