summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gnome-mount')
-rw-r--r--gnome-base/gnome-mount/ChangeLog6
-rw-r--r--gnome-base/gnome-mount/files/gnome-mount-0.6-include-locale-h.patch10
-rw-r--r--gnome-base/gnome-mount/gnome-mount-0.6.ebuild3
3 files changed, 17 insertions, 2 deletions
diff --git a/gnome-base/gnome-mount/ChangeLog b/gnome-base/gnome-mount/ChangeLog
index 840687b10fe9..0bff75d052ef 100644
--- a/gnome-base/gnome-mount/ChangeLog
+++ b/gnome-base/gnome-mount/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-base/gnome-mount
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-mount/ChangeLog,v 1.34 2007/05/17 14:14:37 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-mount/ChangeLog,v 1.35 2007/05/29 20:48:45 remi Exp $
+
+ 29 May 2007; Remi Cardona <remi@gentoo.org>
+ +files/gnome-mount-0.6-include-locale-h.patch, gnome-mount-0.6.ebuild:
+ add #include <locale.h> to fix bug #176035
17 May 2007; Roy Marples <uberlord@gentoo.org>
+files/gnome-mount-0.6-freebsd-schemas.patch, gnome-mount-0.6.ebuild:
diff --git a/gnome-base/gnome-mount/files/gnome-mount-0.6-include-locale-h.patch b/gnome-base/gnome-mount/files/gnome-mount-0.6-include-locale-h.patch
new file mode 100644
index 000000000000..25252ca5dfd8
--- /dev/null
+++ b/gnome-base/gnome-mount/files/gnome-mount-0.6-include-locale-h.patch
@@ -0,0 +1,10 @@
+--- src/gnome-mount.c 2007-05-29 22:28:51.000000000 +0200
++++ src/gnome-mount.c 2007-05-29 21:15:55.000000000 +0200
+@@ -25,6 +25,7 @@
+ #endif
+
+ #include <unistd.h>
++#include <locale.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
diff --git a/gnome-base/gnome-mount/gnome-mount-0.6.ebuild b/gnome-base/gnome-mount/gnome-mount-0.6.ebuild
index a074827bd3ad..ac792fbb06ea 100644
--- a/gnome-base/gnome-mount/gnome-mount-0.6.ebuild
+++ b/gnome-base/gnome-mount/gnome-mount-0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-mount/gnome-mount-0.6.ebuild,v 1.3 2007/05/17 14:14:37 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-mount/gnome-mount-0.6.ebuild,v 1.4 2007/05/29 20:48:45 remi Exp $
inherit eutils gnome2
@@ -40,4 +40,5 @@ src_unpack() {
gnome2_src_unpack
use kernel_FreeBSD && epatch "${FILESDIR}/${P}"-freebsd-schemas.patch
+ epatch "${FILESDIR}/${PN}-0.6-include-locale-h.patch"
}