summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/nautilus-sendto/files/nautilus-sendto-0.14-configure-options.patch')
-rw-r--r--gnome-extra/nautilus-sendto/files/nautilus-sendto-0.14-configure-options.patch243
1 files changed, 243 insertions, 0 deletions
diff --git a/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.14-configure-options.patch b/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.14-configure-options.patch
new file mode 100644
index 000000000000..21f37bf475f4
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.14-configure-options.patch
@@ -0,0 +1,243 @@
+--- configure.in.orig 2008-03-29 13:06:51.000000000 -0700
++++ configure.in 2008-03-29 13:26:47.000000000 -0700
+@@ -65,18 +65,16 @@
+ dnl Libebook support
+ dnl ---------------------------------
+
+-PKG_CHECK_MODULES(NST_EBOOK, libebook-1.2 >= $EBOOK_REQUIRED,
+- [
+- AC_SUBST(NST_EBOOK_CFLAGS)
+- AC_SUBST(NST_EBOOK_LIBS)
+- echo "Using libebook-1.2 !"
+- enable_evolution=yes
+- ],
+- [
+- echo "Building without evolution"
+- enable_evolution=no
+- ]
+-)
++AC_ARG_ENABLE([evolution],
++ AS_HELP_STRING([--enable-evolution], [enable support for evolution]),,
++ [enable_evolution=no])
++
++if test x$enable_evolution = xyes ; then
++ PKG_CHECK_MODULES(NST_EBOOK, [libebook-1.2 >= $EBOOK_REQUIRED])
++
++ AC_SUBST([NST_EBOOK_CFLAGS])
++ AC_SUBST([NST_EBOOK_LIBS])
++fi
+
+ AM_CONDITIONAL(HAVE_EVOLUTION, test "x$enable_evolution" = "xyes")
+
+@@ -85,87 +83,88 @@
+ AC_CHECK_TYPES([EContactPhotoType], , , [#include <libebook/e-contact.h>])
+ CPPFLAGS="$saved_CPPFLAGS"
+
+-dnl Gaim support if it's installed
++dnl Gaim support
+ dnl ---------------------------------
+
++AC_ARG_ENABLE([gaim],
++ AS_HELP_STRING([--enable-gaim], [enable support for gaim]),,
++ [enable_gaim=no])
++
++if test x$enable_gaim = xyes ; then
++ PKG_CHECK_MODULES(GAIM, [gaim >= $GAIM_REQUIRED])
++
++ AC_SUBST([GAIM_CFLAGS])
++ AC_SUBST([GAIM_LIBS])
+
+-PKG_CHECK_MODULES(GAIM, gaim >= $GAIM_REQUIRED,
+- [
+- AC_SUBST(GAIM_CFLAGS)
+- AC_SUBST(GAIM_LIBS)
+- GAIM_LIBDIR=`pkg-config --variable=libdir gaim`
+- GAIM_DATADIR=`pkg-config --variable=datadir gaim`
+- AC_SUBST(GAIM_LIBDIR)
+- AC_SUBST(GAIM_DATADIR)
+- enable_gaim=yes
+- ],
+- [
+- echo "Building without gaim"
+- enable_gaim=no
+- ]
+-)
++ GAIM_LIBDIR=`pkg-config --variable=libdir gaim`
++ GAIM_DATADIR=`pkg-config --variable=datadir gaim`
++
++ AC_SUBST([GAIM_LIBDIR])
++ AC_SUBST([GAIM_DATADIR])
++fi
+
+ AM_CONDITIONAL(HAVE_GAIM, test "x$enable_gaim" = "xyes")
+
+-dnl Pidgin support if it's installed
++dnl Pidgin support
+ dnl ---------------------------------
+
++AC_ARG_ENABLE([pidgin],
++ AS_HELP_STRING([--enable-pidgin], [enable support for pidgin]),,
++ [enable_pidgin=no])
++
++if test x$enable_pidgin = xyes ; then
++ PKG_CHECK_MODULES(PIDGIN, [pidgin >= $PIDGIN_REQUIRED purple >= $PIDGIN_REQUIRED])
++
++ AC_SUBST([PIDGIN_CFLAGS])
++ AC_SUBST([PIDGIN_LIBS])
+
+-PKG_CHECK_MODULES(PIDGIN, pidgin >= $PIDGIN_REQUIRED purple >= $PIDGIN_REQUIRED,
+- [
+- AC_SUBST(PIDGIN_CFLAGS)
+- AC_SUBST(PIDGIN_LIBS)
+- PIDGIN_LIBDIR=`pkg-config --variable=libdir purple`
+- PIDGIN_DATADIR=`pkg-config --variable=datadir purple`
+- AC_SUBST(PIDGIN_LIBDIR)
+- AC_SUBST(PIDGIN_DATADIR)
+- enable_pidgin=yes
+- ],
+- [
+- echo "Building without pidgin"
+- enable_pidgin=no
+- ]
+-)
++ PIDGIN_LIBDIR=`pkg-config --variable=libdir purple`
++ PIDGIN_DATADIR=`pkg-config --variable=datadir purple`
++
++ AC_SUBST([PIDGIN_LIBDIR])
++ AC_SUBST([PIDGIN_DATADIR])
++fi
+
+ AM_CONDITIONAL(HAVE_PIDGIN, test "x$enable_pidgin" = "xyes")
+
+-dnl Bluetooth support if it's installed
++dnl Bluetooth support
+ dnl -----------------------------------
+
+-PKG_CHECK_MODULES(BLUETOOTH, dbus-glib-1 >= $DBUS_GLIB_REQUIRED,
+- [
+- AC_SUBST(BLUETOOTH_CFLAGS)
+- AC_SUBST(BLUETOOTH_LIBS)
+- enable_bluetooth=yes
+- ],
+- [
+- echo "Building without Bluetooth"
+- enable_bluetooth=no
+- ]
+-)
++AC_ARG_ENABLE([bluetooth],
++ AS_HELP_STRING([--enable-bluetooth], [enable support for bluetooth]),,
++ [enable_bluetooth=yes])
++
++if test x$enable_bluetooth = xyes ; then
++ PKG_CHECK_MODULES(BLUETOOTH, [dbus-glib-1 >= $DBUS_GLIB_REQUIRED])
++
++ AC_SUBST([BLUETOOTH_CLFAGS])
++ AC_SUBST([BLUETOOTH_LIBS])
++fi
+
+ AM_CONDITIONAL(HAVE_BLUETOOTH, test "x$enable_bluetooth" = "xyes")
+
++dnl --------------------------------------------------
++
+ GLIB_GENMARSHAL=`$PKG_CONFIG --variable=glib_genmarshal glib-2.0`
+ AC_SUBST(GLIB_GENMARSHAL)
+
+-dnl --------------------------------------------------
+-
+ dnl Balsa support
+ dnl -------------------------------------------------
+
+-enable_balsa=no
+-AM_CONDITIONAL(HAVE_BALSA, test "x$enable_balsa" = "xyes")
+-dnl -------------------------------------------------
++AC_ARG_ENABLE([balsa],
++ AS_HELP_STRING([--enable-balsa], [enable support for balsa]),,
++ [enable_balsa=no])
+
++AM_CONDITIONAL(HAVE_BALSA, test "x$enable_balsa" = "xyes")
+
+ dnl Sylpheed support
+ dnl -------------------------------------------------
+
+-enable_sylpheed=yes
+-AM_CONDITIONAL(HAVE_SYLPHEED, test "x$enable_sylpheed" = "xyes")
+-dnl -------------------------------------------------
++AC_ARG_ENABLE([sylpheed],
++ AS_HELP_STRING([--enable-sylpheed], [enable support for sylpheed]),,
++ [enable_sylpheed=yes])
+
++AM_CONDITIONAL(HAVE_SYLPHEED, test "x$enable_sylpheed" = "xyes")
+
+ dnl Thunderbird support
+ dnl -------------------------------------------------
+@@ -182,49 +181,45 @@
+
+ AC_DEFINE_UNQUOTED(THUNDERBIRD_NAME, "$THUNDERBIRD_NAME", [name of the Thunderbird binary])
+
+-enable_thunderbird=yes
+-AM_CONDITIONAL(HAVE_THUNDERBIRD, test "x$enable_thunderbird" = "xyes")
++AC_ARG_ENABLE([thunderbird],
++ AS_HELP_STRING([--enable-thunderbird], [enable support for thunderbird]),,
++ [enable_thunderbird=yes])
+
+-dnl -------------------------------------------------
++AM_CONDITIONAL(HAVE_THUNDERBIRD, test "x$enable_thunderbird" = "xyes")
+
+ dnl Gajim support
+ dnl -------------------------------------------------
+
++AC_ARG_ENABLE([gajim],
++ AS_HELP_STRING([--enable-gajim], [enable support for gajim]),,
++ [enable_gajim=no])
++
++if test x$enable_gajim = xyes ; then
++ PKG_CHECK_MODULES(DBUS, [dbus-1 >= $DBUS_REQUIRED dbus-glib-1 >= $DBUS_GLIB_REQUIRED])
++
++ AC_SUBST(DBUS_CFLAGS)
++ AC_SUBST(DBUS_LIBS)
++fi
++
+ AC_ARG_WITH(gajim,
+- [AS_HELP_STRING(--with-gajim,[Path to Gajim install prefix])],
+- [GAJIM_PATH="$withval"],[GAJIM_PATH="$prefix"])
++ AS_HELP_STRING([--with-gajim], [Path to gajim install prefix]),
++ [GAJIM_PATH="$withval"], [GAJIM_PATH="$prefix"])
+
+ GAJIM_SHARE_DIR="$GAJIM_PATH"/share/gajim
+
+-PKG_CHECK_MODULES(DBUS, dbus-1 >= $DBUS_REQUIRED dbus-glib-1 >= $DBUS_GLIB_REQUIRED,
+- [
+- AC_SUBST(DBUS_CFLAGS)
+- AC_SUBST(DBUS_LIBS)
+- if test -f "$GAJIM_SHARE_DIR"/data/pixmaps/gajim.png ;
+- then
+- enable_gajim=yes
+- AC_DEFINE_UNQUOTED(GAJIM_SHARE_DIR, "$GAJIM_SHARE_DIR", [path to gajim share dir])
+- else
+- echo "Building without Gajim support"
+- enable_gajim=no
+- fi
+- ],
+- [
+- echo "Building without Gajim support"
+- enable_gajim=no
+- ]
+-)
++if test -f "$GAJIM_SHARE_DIR"/data/pixmaps/gajim.png ; then
++ AC_DEFINE_UNQUOTED(GAJIM_SHARE_DIR, "$GAJIM_SHARE_DIR", [path to gajim share dir])
++fi
+
+ AM_CONDITIONAL(HAVE_GAJIM, test "x$enable_gajim" = "xyes")
+
+ dnl -------------------------------------------------
+-
+ IT_PROG_INTLTOOL([0.35.0])
+
+ GETTEXT_PACKAGE=nautilus-sendto
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [GetText Package])
+-
++
+ AM_GLIB_GNU_GETTEXT
+
+ AC_PATH_PROG(GCONFTOOL, gconftool-2)