summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-exchange/ChangeLog9
-rw-r--r--gnome-extra/evolution-exchange/evolution-exchange-2.22.3-r1.ebuild52
-rw-r--r--gnome-extra/evolution-exchange/files/evolution-exchange-2.22.3-addressbook-crash.patch55
3 files changed, 115 insertions, 1 deletions
diff --git a/gnome-extra/evolution-exchange/ChangeLog b/gnome-extra/evolution-exchange/ChangeLog
index c499edd12d9b..45580c2c4cfe 100644
--- a/gnome-extra/evolution-exchange/ChangeLog
+++ b/gnome-extra/evolution-exchange/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/evolution-exchange
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.66 2008/07/30 21:48:30 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.67 2008/08/06 22:32:03 eva Exp $
+
+*evolution-exchange-2.22.3-r1 (06 Aug 2008)
+
+ 06 Aug 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/evolution-exchange-2.22.3-addressbook-crash.patch,
+ +evolution-exchange-2.22.3-r1.ebuild:
+ fix crash in addressbook, bug #233263.
*evolution-exchange-2.22.3 (30 Jul 2008)
diff --git a/gnome-extra/evolution-exchange/evolution-exchange-2.22.3-r1.ebuild b/gnome-extra/evolution-exchange/evolution-exchange-2.22.3-r1.ebuild
new file mode 100644
index 000000000000..0ee1ebae67c2
--- /dev/null
+++ b/gnome-extra/evolution-exchange/evolution-exchange-2.22.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/evolution-exchange-2.22.3-r1.ebuild,v 1.1 2008/08/06 22:32:03 eva Exp $
+EAPI="1"
+
+inherit gnome2 eutils
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
+HOMEPAGE="http://www.novell.com/products/desktop/features/evolution.html"
+LICENSE="GPL-2"
+
+SLOT="2.0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="debug doc static"
+
+RDEPEND="
+ >=mail-client/evolution-2.21.90
+ >=dev-libs/glib-2.15.3
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/gconf-2.0
+ >=gnome-base/libbonobo-2.20.3
+ >=gnome-base/libglade-2.0
+ >=gnome-base/libgnomeui-2.0
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ >=gnome-extra/evolution-data-server-2.22.3
+ >=net-nds/openldap-2.1.30-r2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.5
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_with debug e2k-debug)"
+
+ if ! built_with_use gnome-extra/evolution-data-server ldap || ! built_with_use gnome-extra/evolution-data-server kerberos; then
+ eerror "Please re-emerge gnome-extra/evolution-data-server with"
+ eerror "the use flags ldap and kerberos."
+ die
+ fi
+
+ G2CONF="${G2CONF} $(use_with static static-ldap) --with-openldap"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch "${FILESDIR}/${P}-addressbook-crash.patch"
+}
diff --git a/gnome-extra/evolution-exchange/files/evolution-exchange-2.22.3-addressbook-crash.patch b/gnome-extra/evolution-exchange/files/evolution-exchange-2.22.3-addressbook-crash.patch
new file mode 100644
index 000000000000..c24f956a1ef0
--- /dev/null
+++ b/gnome-extra/evolution-exchange/files/evolution-exchange-2.22.3-addressbook-crash.patch
@@ -0,0 +1,55 @@
+Index: addressbook/e-book-backend-exchange.c
+===================================================================
+--- addressbook/e-book-backend-exchange.c
++++ addressbook/e-book-backend-exchange.c
+@@ -1766,17 +1766,21 @@ e_book_backend_exchange_build_restrictio
+ r = e_sexp_eval (sexp);
+ if (r && r->type == ESEXP_RES_UNDEFINED)
+ rn = (E2kRestriction *)r->value.string;
+- else {
+- g_warning ("conversion to exchange restriction failed");
++ else
+ rn = NULL;
+- }
++
++ if (!rn)
++ g_warning ("conversion to exchange restriction failed, query: '%s'", query ? query : "[null]");
+
+ e_sexp_result_free (sexp, r);
+ e_sexp_unref (sexp);
+
+- if (base_rn) {
++ if (base_rn && rn) {
+ e2k_restriction_ref (base_rn);
+ rn = e2k_restriction_andv (rn, base_rn, NULL);
++
++ if (!rn)
++ g_warning ("failed to concat with a base_rn, query: '%s'", query ? query : "[null]");
+ }
+
+ return rn;
+@@ -1890,9 +1894,14 @@ e_book_backend_exchange_get_contact_list
+
+ rn = e_book_backend_exchange_build_restriction (query,
+ bepriv->base_rn);
++
++ if (!rn)
++ return GNOME_Evolution_Addressbook_OtherError;
++
+ iter = e_folder_exchange_search_start (bepriv->folder, NULL,
+ field_names, n_field_names,
+ rn, NULL, TRUE);
++
+ e2k_restriction_unref (rn);
+
+ *contacts = NULL;
+@@ -1986,6 +1995,9 @@ e_book_backend_exchange_start_book_view
+ rn = e_book_backend_exchange_build_restriction (query,
+ bepriv->base_rn);
+
++ if (!rn)
++ return;
++
+ iter = e_folder_exchange_search_start (bepriv->folder, NULL,
+ field_names, n_field_names,
+ rn, NULL, TRUE);