summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/ark/files/ark-4.4.5-detect-libarchive-in-proper-place.patch')
-rw-r--r--kde-base/ark/files/ark-4.4.5-detect-libarchive-in-proper-place.patch25
1 files changed, 0 insertions, 25 deletions
diff --git a/kde-base/ark/files/ark-4.4.5-detect-libarchive-in-proper-place.patch b/kde-base/ark/files/ark-4.4.5-detect-libarchive-in-proper-place.patch
deleted file mode 100644
index 452830f83a1c..000000000000
--- a/kde-base/ark/files/ark-4.4.5-detect-libarchive-in-proper-place.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/ark/CMakeLists.txt b/ark/CMakeLists.txt
-index 6ea72bb..85c5ce0 100644
---- a/ark/CMakeLists.txt
-+++ b/ark/CMakeLists.txt
-@@ -1,5 +1,8 @@
- project(ark)
-
-+macro_optional_find_package(LibArchive)
-+macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://code.google.com/p/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark.")
-+
- configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
-
- add_subdirectory(part)
-diff --git a/ark/plugins/CMakeLists.txt b/ark/plugins/CMakeLists.txt
-index a8c4e44..e3cb9ec 100644
---- a/ark/plugins/CMakeLists.txt
-+++ b/ark/plugins/CMakeLists.txt
-@@ -1,7 +1,3 @@
--macro_optional_find_package(LibArchive)
--
--macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://people.freebsd.org/~kientzle/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark. Make sure it is compiled with gzip support.")
--
- if (LIBARCHIVE_FOUND)
- if( NOT HAVE_LIBARCHIVE_LZMA_SUPPORT OR NOT HAVE_LIBARCHIVE_XZ_SUPPORT )
- message(STATUS "Your libarchive does not have support for lzma and/or xz archives. libarchive >= 2.7.0 is recommended.")