summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kbabel/kbabel-3.5.2.ebuild')
-rw-r--r--kde-base/kbabel/kbabel-3.5.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/kbabel/kbabel-3.5.2.ebuild b/kde-base/kbabel/kbabel-3.5.2.ebuild
new file mode 100644
index 000000000000..965dcdb0bf6c
--- /dev/null
+++ b/kde-base/kbabel/kbabel-3.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kbabel/kbabel-3.5.2.ebuild,v 1.1 2006/03/22 20:14:57 danarmak Exp $
+
+KMNAME=kdesdk
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KBabel - An advanced PO file editor"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="berkdb"
+
+DEPEND="sys-devel/flex
+ berkdb? ( || ( =sys-libs/db-4.3*
+ =sys-libs/db-4.2* ) )"
+
+src_compile() {
+ local myconf=""
+
+ if use berkdb; then
+ if has_version "=sys-libs/db-4.3*"; then
+ myconf="${myconf} --with-berkeley-db --with-db-name=db-4.3
+ --with-db-include-dir=/usr/include/db4.3"
+ elif has_version "=sys-libs/db-4.2*"; then
+ myconf="${myconf} --with-berkeley-db --with-db-name=db-4.2
+ --with-db-include-dir=/usr/include/db4.2"
+ fi
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ kde_src_compile
+}