summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kcheckpass/kcheckpass-4.7.1.ebuild')
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.7.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-base/kcheckpass/kcheckpass-4.7.1.ebuild b/kde-base/kcheckpass/kcheckpass-4.7.1.ebuild
new file mode 100644
index 000000000000..2a35fe4b0943
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.7.1.ebuild,v 1.1 2011/09/07 20:13:48 alexxy Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+DEPEND="${RDEPEND}
+ x11-libs/libxkbfile
+"
+
+PATCHES=(
+ "${FILESDIR}/kdebase-4.0.2-pam-optional.patch"
+)
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}