summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kde-i18n/kde-i18n-2.0.ebuild')
-rw-r--r--kde-base/kde-i18n/kde-i18n-2.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-base/kde-i18n/kde-i18n-2.0.ebuild b/kde-base/kde-i18n/kde-i18n-2.0.ebuild
new file mode 100644
index 000000000000..9fcb436b6300
--- /dev/null
+++ b/kde-base/kde-i18n/kde-i18n-2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-i18n/kde-i18n-2.0.ebuild,v 1.1 2000/10/29 20:42:02 achim Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="KDE 2Beta - Language Support"
+SRC_PATH="kde/stable/2.0/distribution/tar/generic/src/${A}"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH"
+
+HOMEPAGE="http://www.kde.org/"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+# rm -r ca
+
+}
+src_compile() {
+ cd ${S}
+ rm catalog
+ find /usr/share/sgml -name "catalog" -print -exec install-catalog -a catalog {} \;
+ export SGML_CATALOG_FILES=${S}/catalog
+ try ./configure --prefix=/opt/kde2 --host=${CHOST} \
+ --with-qt-dir=/usr/lib/qt-x11-2.2.1 \
+ --with-qt-includes=/usr/lib/qt-x11-2.2.1/include \
+ --with-qt-libs=/usr/lib/qt-x11-2.2.1/lib
+ cp Makefile Makefile.orig
+ sed -e "s:^TOPSUBDIRS = .*:TOPSUBDIRS = ca cs da de el en_GB eo es et fi fr he hr hu is it mk nl no no_NY pl pt pt_BR ro ru sk sl sv ta tr uk:" Makefile.orig > Makefile
+ try SGML_CATALOG_FILES=${S}/catalog make
+}
+
+src_install() {
+ try make install DESTDIR=${D}
+ dodoc COPYING highscore
+ docinto html
+ dodoc highscore.html
+}
+
+
+