summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdebase/files/kdebase-3.5.0_beta2-noimake.patch')
-rw-r--r--kde-base/kdebase/files/kdebase-3.5.0_beta2-noimake.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/kde-base/kdebase/files/kdebase-3.5.0_beta2-noimake.patch b/kde-base/kdebase/files/kdebase-3.5.0_beta2-noimake.patch
new file mode 100644
index 000000000000..1f84c2f00460
--- /dev/null
+++ b/kde-base/kdebase/files/kdebase-3.5.0_beta2-noimake.patch
@@ -0,0 +1,58 @@
+diff -Nur kdebase-3.4.92.orig/kdm/configure.in.in kdebase-3.4.92/kdm/configure.in.in
+--- kdebase-3.4.92.orig/kdm/configure.in.in 2005-10-10 17:04:31.000000000 +0200
++++ kdebase-3.4.92/kdm/configure.in.in 2005-10-19 15:30:11.000000000 +0200
+@@ -1,39 +1,19 @@
+-KDE_FIND_PATH(xmkmf, XMKMF, [], [AC_MSG_ERROR([xmkmf/imake not found. Please make sure it's in PATH!])])
++AC_MSG_CHECKING([X paths for KDM])
+
+-dnl ask imake about various X settings
+-AC_MSG_CHECKING([X paths])
+-imkv=8
+-test "$kde_cv_defines_imake_version" = $imkv || unset kde_cv_defines_imake
+-AC_CACHE_VAL(kde_cv_defines_imake, [
+- rm -fr conftestdir
+- if mkdir conftestdir; then
+- cd conftestdir
+- cat > Imakefile <<'EOF'[
+-
+-acimake:
+- @echo "XBINDIR=\"$(BINDIR)\" XLIBDIR=\"$(LIBDIR)\""
+-
+-]EOF
+- if $XMKMF >&5 2>&1 && test -f Makefile; then
+- kde_cv_defines_imake=`${MAKE-make} acimake 2> /dev/null | grep -v "^make"`
+- kde_cv_defines_imake_version=$imkv
+- else
+- AC_MSG_RESULT([failed])
+- AC_MSG_ERROR([$XMKMF (imake) failed.
+-Make sure you have all necessary X development packages installed.
+-On some systems a missing /lib/cpp symlink is at fault.])
+- fi
+- cd ..
+- rm -fr conftestdir
+- else
+- AC_MSG_RESULT([failed])
+- AC_MSG_ERROR([cannot create temporary directory])
+- fi
+-])
+-AC_MSG_RESULT([done])
+-eval "$kde_cv_defines_imake"
+-AC_DEFINE_UNQUOTED(XBINDIR, "$XBINDIR", [X binaries directory])
+-AC_DEFINE_UNQUOTED(XLIBDIR, "$XLIBDIR", [X libraries directory])
++AC_ARG_WITH(x-binaries-dir,
++ [AS_HELP_STRING(--with-x-binaries-dir=DIR,
++ [set the location of X binaries for KDM])],
++ [], [with_x_binaries_dir=`echo $kde_x_libraries | sed -e 's,/lib.*,/bin,'`])
++
++AC_ARG_WITH(x-libraries-dir,
++ [AS_HELP_STRING(--with-x-libraries-dir=DIR,
++ [set the location of X libraries for KDM])],
++ [], [with_x_libraries_dir=$kde_x_libraries])
++
++AC_MSG_RESULT([binaries in $with_x_binaries_dir, libraries in $with_x_libraries_dir])
++
++AC_DEFINE_UNQUOTED(XBINDIR, "$with_x_binaries_dir", [X binaries directory])
++AC_DEFINE_UNQUOTED(XLIBDIR, "$with_x_libraries_dir", [X libraries directory])
+
+ if test -f /etc/ttys; then
+ AC_DEFINE(BSD_INIT, 1, [Define if the system uses a BSD-style init])