summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdesdk/kdesdk-3.5_beta1-r1.ebuild')
-rw-r--r--kde-base/kdesdk/kdesdk-3.5_beta1-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/kde-base/kdesdk/kdesdk-3.5_beta1-r1.ebuild b/kde-base/kdesdk/kdesdk-3.5_beta1-r1.ebuild
new file mode 100644
index 000000000000..598f1e1de388
--- /dev/null
+++ b/kde-base/kdesdk/kdesdk-3.5_beta1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesdk/kdesdk-3.5_beta1-r1.ebuild,v 1.1 2005/09/28 14:26:24 flameeyes Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE SDK: Cervisia, KBabel, KCachegrind, Kompare, Umbrello,..."
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~hppa"
+IUSE="berkdb subversion"
+
+DEPEND="x86? ( dev-util/callgrind )
+ sys-devel/flex
+ subversion? ( dev-util/subversion )
+ berkdb? ( || ( =sys-libs/db-4.3*
+ =sys-libs/db-4.2* ) )"
+
+RDEPEND="${DEPEND}
+ dev-util/cvs
+ media-gfx/graphviz"
+
+src_unpack() {
+ kde_src_unpack
+
+ # Configure patch.
+ epatch "${FILESDIR}/kdesdk-3.5-configure-db.patch"
+
+ # Fix compilation. Applied for rc1.
+ epatch "${FILESDIR}/${P}-compile.patch"
+ # Fix crash. Applied for rc1.
+ epatch "${FILESDIR}/${P}-crash.patch"
+
+ # For the configure patch.
+ make -f admin/Makefile.common
+}
+
+src_compile() {
+ local myconf="$(use_with subversion)"
+
+ if use berkdb; then
+ if has_version "=sys-libs/db-4.3*"; then
+ myconf="${myconf} --with-berkeley-db --with-db-name=db-4.3
+ --with-db-include-dir=/usr/include/db4.3"
+ elif has_version "=sys-libs/db-4.2*"; then
+ myconf="${myconf} --with-berkeley-db --with-db-name=db-4.2
+ --with-db-include-dir=/usr/include/db4.2"
+ fi
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ kde_src_compile
+}