summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdesu/kdesu-4.8.1.ebuild')
-rw-r--r--kde-base/kdesu/kdesu-4.8.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/kde-base/kdesu/kdesu-4.8.1.ebuild b/kde-base/kdesu/kdesu-4.8.1.ebuild
new file mode 100644
index 000000000000..05991851c1ea
--- /dev/null
+++ b/kde-base/kdesu/kdesu-4.8.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesu/kdesu-4.8.1.ebuild,v 1.1 2012/03/06 23:35:32 dilfridge Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-runtime"
+inherit kde4-meta
+
+# FIXME: Is default command ( su/sudo ) still configurable,
+# if not, USE-flag ?
+DESCRIPTION="KDE: gui for su(1)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+src_configure() {
+ # Upstream moved kdesu to libexec first, then decided to move it back
+ # to /${PREFIX}/bin/ , so I'm doing that now already.
+ sed -e '/kdesu_executable/s:LIBEXEC_INSTALL_DIR:BIN_INSTALL_DIR:' \
+ -i "${S}"/kdesu/kdesu/CMakeLists.txt || \
+ die "Moving kdesu from libexec to bin failed."
+
+ kde4-meta_src_configure
+}