summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kget/kget-4.12.1.ebuild')
-rw-r--r--kde-base/kget/kget-4.12.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-base/kget/kget-4.12.1.ebuild b/kde-base/kget/kget-4.12.1.ebuild
new file mode 100644
index 000000000000..e6f77862a053
--- /dev/null
+++ b/kde-base/kget/kget-4.12.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kget/kget-4.12.1.ebuild,v 1.1 2014/01/18 11:23:58 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="An advanced download manager for KDE"
+HOMEPAGE="http://www.kde.org/applications/internet/kget/"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug bittorrent mms semantic-desktop sqlite webkit"
+
+RDEPEND="
+ app-crypt/qca:2
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ $(add_kdebase_dep libkworkspace '' 4.11)
+ bittorrent? ( >=net-libs/libktorrent-1.0.3 )
+ mms? ( media-libs/libmms )
+ semantic-desktop? (
+ dev-libs/shared-desktop-ontologies
+ dev-libs/soprano
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep nepomuk-core)
+ $(add_kdebase_dep nepomuk-widgets)
+ )
+ sqlite? ( dev-db/sqlite:3 )
+ webkit? ( >=kde-misc/kwebkitpart-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with bittorrent KTorrent)
+ $(cmake-utils_use_with mms LibMms)
+ $(cmake-utils_use_with semantic-desktop NepomukCore)
+ $(cmake-utils_use_with semantic-desktop NepomukWidgets)
+ $(cmake-utils_use_with semantic-desktop QGpgme)
+ $(cmake-utils_use_with sqlite)
+ $(cmake-utils_use_with webkit KWebKitPart)
+ )
+ kde4-base_src_configure
+}