summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kigo/kigo-4.5.3.ebuild')
-rw-r--r--kde-base/kigo/kigo-4.5.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/kigo/kigo-4.5.3.ebuild b/kde-base/kigo/kigo-4.5.3.ebuild
new file mode 100644
index 000000000000..b413fbb3b25e
--- /dev/null
+++ b/kde-base/kigo/kigo-4.5.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kigo/kigo-4.5.3.ebuild,v 1.1 2010/11/03 16:30:22 scarabeus Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdegames"
+inherit games-ggz kde4-meta
+
+DESCRIPTION="KDE Go game"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="
+ games-board/gnugo
+"
+
+src_install() {
+ kde4-meta_src_install
+ # and also we have to prepare the ggz dir
+ insinto /usr/share/ggz/modules
+ newins ${PN}/src/module.dsc ${P}.dsc || die "couldn't install .dsc file"
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ games-ggz_pkg_postinst
+}
+
+pkg_postrm() {
+ kde4-meta_pkg_postrm
+ games-ggz_pkg_postrm
+}