summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kinfocenter/kinfocenter-4.8.1.ebuild')
-rw-r--r--kde-base/kinfocenter/kinfocenter-4.8.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/kinfocenter/kinfocenter-4.8.1.ebuild b/kde-base/kinfocenter/kinfocenter-4.8.1.ebuild
new file mode 100644
index 000000000000..1b5fa2e35aed
--- /dev/null
+++ b/kde-base/kinfocenter/kinfocenter-4.8.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kinfocenter/kinfocenter-4.8.1.ebuild,v 1.1 2012/03/06 23:35:02 dilfridge Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="The KDE Info Center"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug ieee1394"
+
+DEPEND="
+ $(add_kdebase_dep solid)
+ sys-apps/pciutils
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ virtual/glu
+ virtual/opengl
+ )
+"
+RDEPEND="${DEPEND}
+ sys-apps/usbutils
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with ieee1394 RAW1394)
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-meta_src_configure
+}