summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/libkpimexchange')
-rw-r--r--kde-base/libkpimexchange/ChangeLog8
-rw-r--r--kde-base/libkpimexchange/files/digest-libkpimexchange-3.5.83
-rw-r--r--kde-base/libkpimexchange/libkpimexchange-3.5.8.ebuild34
3 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/libkpimexchange/ChangeLog b/kde-base/libkpimexchange/ChangeLog
index abc045cdb1d8..204dfbfd44ea 100644
--- a/kde-base/libkpimexchange/ChangeLog
+++ b/kde-base/libkpimexchange/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/libkpimexchange
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkpimexchange/ChangeLog,v 1.74 2007/08/11 15:32:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkpimexchange/ChangeLog,v 1.75 2007/10/19 23:51:41 philantrop Exp $
+
+*libkpimexchange-3.5.8 (19 Oct 2007)
+
+ 19 Oct 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +libkpimexchange-3.5.8.ebuild:
+ Bump to KDE 3.5.8.
11 Aug 2007; Raúl Porcel <armin76@gentoo.org>
libkpimexchange-3.5.7.ebuild:
diff --git a/kde-base/libkpimexchange/files/digest-libkpimexchange-3.5.8 b/kde-base/libkpimexchange/files/digest-libkpimexchange-3.5.8
new file mode 100644
index 000000000000..829a0a174fc3
--- /dev/null
+++ b/kde-base/libkpimexchange/files/digest-libkpimexchange-3.5.8
@@ -0,0 +1,3 @@
+MD5 a1ffff553f1d6739c7791891028b176b kdepim-3.5.8.tar.bz2 14107449
+RMD160 bb34c7e88227a1ebdd8ff38ee41445f85969175e kdepim-3.5.8.tar.bz2 14107449
+SHA256 433f8541af0a05e0a7e15df5ecca8463a29b6574871b941a8312b04b2233fef1 kdepim-3.5.8.tar.bz2 14107449
diff --git a/kde-base/libkpimexchange/libkpimexchange-3.5.8.ebuild b/kde-base/libkpimexchange/libkpimexchange-3.5.8.ebuild
new file mode 100644
index 000000000000..a7a35331d57f
--- /dev/null
+++ b/kde-base/libkpimexchange/libkpimexchange-3.5.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkpimexchange/libkpimexchange-3.5.8.ebuild,v 1.1 2007/10/19 23:51:41 philantrop Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE PIM exchange library"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkcal)"
+
+RDEPEND="${DEPEND}"
+
+KMCOPYLIB="libkcal libkcal"
+# libkcal is installed because a lot of headers are needed, but it don't have to be compiled
+KMEXTRACTONLY="
+ libkcal/"
+KMCOMPILEONLY="
+ libkcal/libical/src/libical/
+ libkcal/libical/src/libicalss/"
+
+src_compile() {
+ kde-meta_src_compile myconf configure
+ # generate "ical.h"
+ cd "${S}/libkcal/libical/src/libical" && make ical.h
+ # generate "icalss.h"
+ cd "${S}/libkcal/libical/src/libicalss" && make icalss.h
+
+ kde-meta_src_compile make
+}