summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/quanta/quanta-3.4.3.ebuild')
-rw-r--r--kde-base/quanta/quanta-3.4.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-base/quanta/quanta-3.4.3.ebuild b/kde-base/quanta/quanta-3.4.3.ebuild
new file mode 100644
index 000000000000..71a89f5b2a9c
--- /dev/null
+++ b/kde-base/quanta/quanta-3.4.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/quanta/quanta-3.4.3.ebuild,v 1.1 2005/10/13 00:10:08 danarmak Exp $
+KMNAME=kdewebdev
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE: Quanta Plus Web Development Environment"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc tidy"
+DEPEND="dev-libs/libxslt
+ dev-libs/libxml2"
+RDEPEND="$DEPEND
+$(deprange $PV $MAXKDEVER kde-base/kfilereplace)
+$(deprange $PV $MAXKDEVER kde-base/kimagemapeditor)
+$(deprange $PV $MAXKDEVER kde-base/klinkstatus)
+$(deprange $PV $MAXKDEVER kde-base/kommander)
+$(deprange $PV $MAXKDEVER kde-base/kxsldbg)
+tidy? ( app-text/htmltidy )
+doc? ( app-doc/quanta-docs )"
+
+KMCOMPILEONLY=lib
+
+# TODO: check why this wasn't needed back in the monolithic ebuild
+src_compile () {
+ myconf="--with-extra-includes=$(xml2-config --cflags | sed -e 's:^-I::')"
+
+ export LIBXML_LIBS="`xml2-config --libs`"
+ export LIBXSLT_LIBS="`xslt-config --libs`"
+ kde-meta_src_compile
+}