summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.4.ebuild')
-rw-r--r--mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.4.ebuild184
1 files changed, 0 insertions, 184 deletions
diff --git a/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.4.ebuild b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.4.ebuild
deleted file mode 100644
index 12cd336a6eb7..000000000000
--- a/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.4.ebuild
+++ /dev/null
@@ -1,184 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.5.0.4.ebuild,v 1.8 2006/07/26 05:07:02 kumba Exp $
-
-unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
-inherit flag-o-matic toolchain-funcs eutils mozconfig-2 mozilla-launcher makeedit multilib autotools
-
-PVER="0.2"
-
-DESCRIPTION="Thunderbird Mail Client"
-HOMEPAGE="http://www.mozilla.org/projects/thunderbird/"
-SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${PV}/source/thunderbird-${PV}-source.tar.bz2
- mirror://gentoo/${P}-patches-${PVER}.tar.bz2"
-
-KEYWORDS="amd64 ~ia64 ppc sparc x86 ~mips"
-SLOT="0"
-LICENSE="MPL-1.1 NPL-1.1"
-IUSE="ldap crypt"
-
-RDEPEND=">=www-client/mozilla-launcher-1.39
- >=dev-libs/nss-3.10
- >=dev-libs/nspr-4.6.1
- ~sys-devel/autoconf-2.13"
-
-PDEPEND="crypt? ( x11-plugins/enigmail ) "
-
-S=${WORKDIR}/mozilla
-
-# Needed by src_compile() and src_install().
-# Would do in pkg_setup but that loses the export attribute, they
-# become pure shell variables.
-export BUILD_OFFICIAL=1
-export MOZILLA_OFFICIAL=1
-export MOZ_CO_PROJECT=mail
-
-src_unpack() {
- unpack ${A}
- cd ${S} || die "cd failed"
-
- # Apply our patches
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- epatch ${WORKDIR}/patch
-
- # Fix a compilation issue using the 32-bit userland with 64-bit kernel on
- # PowerPC, because with that configuration, it detects a ppc64 system.
- # -- hansmi, 2005-11-13
- if use ppc && [[ "${PROFILE_ARCH}" == ppc64 ]]; then
- sed -i -e "s#OS_TEST=\`uname -m\`\$#OS_TEST=${ARCH}#" \
- ${S}/configure
- sed -i -e "s#OS_TEST :=.*uname -m.*\$#OS_TEST:=${ARCH}#" \
- ${S}/security/coreconf/arch.mk
- fi
-
- WANT_AUTOCONF="2.1" \
- eautoreconf || die "failed running autoreconf"
-}
-
-src_compile() {
- declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
-
- ####################################
- #
- # mozconfig, CFLAGS and CXXFLAGS setup
- #
- ####################################
-
- mozconfig_init
- mozconfig_config
-
- # tb-specific settings
- mozconfig_use_enable ldap
- mozconfig_use_enable ldap ldap-experimental
- mozconfig_annotate '' --enable-extensions=default
- mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
- mozconfig_annotate '' --with-user-appdir=.thunderbird
- mozconfig_annotate '' --with-system-nspr
- mozconfig_annotate '' --with-system-nss
- mozconfig_annotate '' --enable-official-branding
-
- # Finalize and report settings
- mozconfig_final
-
- # hardened GCC uses -fstack-protector-all by default, which breaks us
- gcc-specs-ssp && append-flags -fno-stack-protector-all
- replace-flags -fstack-protector-all -fstack-protector
-
- ####################################
- #
- # Configure and build
- #
- ####################################
- append-flags -freorder-blocks -fno-reorder-functions
-
- # Export CPU_ARCH_TEST as it is not exported by default.
- case $(tc-arch) in
- amd64) [[ ${ABI} == "x86" ]] && CPU_ARCH_TEST="x86" || CPU_ARCH_TEST="x86_64" ;;
- ia64) CPU_ARCH_TEST="ia64" ;;
- ppc) CPU_ARCH_TEST="ppc" ;;
- *) CPU_ARCH_TEST=$(tc-arch) ;;
- esac
-
- export CPU_ARCH_TEST
-
- CPPFLAGS="${CPPFLAGS}" \
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
- econf || die
-
- # This removes extraneous CFLAGS from the Makefiles to reduce RAM
- # requirements while compiling
- edit_makefiles
-
- emake || die
-}
-
-pkg_preinst() {
- declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
-
- echo ""
- einfo "Removing old installs though some really ugly code. It potentially"
- einfo "eliminates any problems during the install, however suggestions to"
- einfo "replace this are highly welcome. Send comments and suggestions to"
- einfo "mozilla@gentoo.org"
- rm -rf ${ROOT}${MOZILLA_FIVE_HOME}
- echo ""
-}
-
-src_install() {
- declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
-
- # Most of the installation happens here
- dodir ${MOZILLA_FIVE_HOME}
- cp -RL "${S}/dist/bin/"* "${D}${MOZILLA_FIVE_HOME}" || die "Copy of files failed"
-
- # Create directory structure to support portage-installed extensions.
- # See update_chrome() in mozilla-launcher
- keepdir ${MOZILLA_FIVE_HOME}/chrome.d
- keepdir ${MOZILLA_FIVE_HOME}/extensions.d
- cp ${D}${MOZILLA_FIVE_HOME}/chrome/installed-chrome.txt \
- ${D}${MOZILLA_FIVE_HOME}/chrome.d/0_base-chrome.txt
-
- # Create /usr/bin/thunderbird
- install_mozilla_launcher_stub thunderbird ${MOZILLA_FIVE_HOME}
-
- # Install icon and .desktop for menu entry
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/icon/thunderbird-icon.png
-
- # Fix bug 54179: Install .desktop file into /usr/share/applications
- # instead of /usr/share/gnome/apps/Internet (18 Jun 2004 agriffis)
- insinto /usr/share/applications
- doins ${FILESDIR}/icon/mozillathunderbird.desktop
-
- ####################################
- #
- # Install files necessary for applications to build against firefox
- #
- ####################################
-
- ewarn "Installing includes and idl files..."
- dodir ${MOZILLA_FIVE_HOME}/idl ${MOZILLA_FIVE_HOME}/include
- cd ${S}/dist
- cp -LfR include/* ${D}${MOZILLA_FIVE_HOME}/include || die "failed to copy"
- cp -LfR idl/* ${D}${MOZILLA_FIVE_HOME}/idl || die "failed to copy"
-
- # Dirty hack to get some applications using this header running
- dosym ${MOZILLA_FIVE_HOME}/include/necko/nsIURI.h \
- /usr/$(get_libdir)/${MOZILLA_FIVE_HOME##*/}/include/nsIURI.h
-}
-
-pkg_postinst() {
- declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
-
- # This should be called in the postinst and postrm of all the
- # mozilla, mozilla-bin, firefox, firefox-bin, thunderbird and
- # thunderbird-bin ebuilds.
- update_mozilla_launcher_symlinks
-}
-
-pkg_postrm() {
- declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
-
- update_mozilla_launcher_symlinks
-}