summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gimp-print')
-rw-r--r--media-gfx/gimp-print/ChangeLog8
-rw-r--r--media-gfx/gimp-print/files/gimp-print-5.0.0_rc1-asneeded.patch243
-rw-r--r--media-gfx/gimp-print/gimp-print-5.0.0_rc1.ebuild43
3 files changed, 272 insertions, 22 deletions
diff --git a/media-gfx/gimp-print/ChangeLog b/media-gfx/gimp-print/ChangeLog
index 8c138dc1a5c1..9a2424b22417 100644
--- a/media-gfx/gimp-print/ChangeLog
+++ b/media-gfx/gimp-print/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/gimp-print
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/ChangeLog,v 1.63 2005/11/02 23:52:51 metalgod Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/ChangeLog,v 1.64 2006/01/04 09:28:18 flameeyes Exp $
+
+ 04 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/gimp-print-5.0.0_rc1-asneeded.patch, gimp-print-5.0.0_rc1.ebuild:
+ Add patch to allowing build with --as-needed (bug #117707).
*gimp-print-5.0.0_rc1 (02 Nov 2005)
diff --git a/media-gfx/gimp-print/files/gimp-print-5.0.0_rc1-asneeded.patch b/media-gfx/gimp-print/files/gimp-print-5.0.0_rc1-asneeded.patch
new file mode 100644
index 000000000000..9182f6e568a4
--- /dev/null
+++ b/media-gfx/gimp-print/files/gimp-print-5.0.0_rc1-asneeded.patch
@@ -0,0 +1,243 @@
+Index: gutenprint-5.0.0-rc1/Makefile.am
+===================================================================
+--- gutenprint-5.0.0-rc1.orig/Makefile.am
++++ gutenprint-5.0.0-rc1/Makefile.am
+@@ -23,7 +23,7 @@ AUTOMAKE_OPTIONS = 1.5 dist-bzip2 check-
+ @SET_MAKE@
+
+ MAINT_CHARSET = latin1
+-ACLOCAL_AMFLAGS = -I m4 -I m4local
++ACLOCAL_AMFLAGS = -I m4 -I m4extra
+
+ include $(top_srcdir)/scripts/global.mk
+
+Index: gutenprint-5.0.0-rc1/m4extra/gtk.m4
+===================================================================
+--- gutenprint-5.0.0-rc1.orig/m4extra/gtk.m4
++++ gutenprint-5.0.0-rc1/m4extra/gtk.m4
+@@ -0,0 +1,194 @@
++# Configure paths for GTK+
++# Owen Taylor 97-11-3
++
++dnl AM_PATH_GTK([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]])
++dnl Test for GTK, and define GTK_CFLAGS and GTK_LIBS
++dnl
++AC_DEFUN(AM_PATH_GTK,
++[dnl
++dnl Get the cflags and libraries from the gtk-config script
++dnl
++AC_ARG_WITH(gtk-prefix,[ --with-gtk-prefix=PFX Prefix where GTK is installed (optional)],
++ gtk_config_prefix="$withval", gtk_config_prefix="")
++AC_ARG_WITH(gtk-exec-prefix,[ --with-gtk-exec-prefix=PFX Exec prefix where GTK is installed (optional)],
++ gtk_config_exec_prefix="$withval", gtk_config_exec_prefix="")
++AC_ARG_ENABLE(gtktest, [ --disable-gtktest Do not try to compile and run a test GTK program],
++ , enable_gtktest=yes)
++
++ for module in . $4
++ do
++ case "$module" in
++ gthread)
++ gtk_config_args="$gtk_config_args gthread"
++ ;;
++ esac
++ done
++
++ if test x$gtk_config_exec_prefix != x ; then
++ gtk_config_args="$gtk_config_args --exec-prefix=$gtk_config_exec_prefix"
++ if test x${GTK_CONFIG+set} != xset ; then
++ GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config
++ fi
++ fi
++ if test x$gtk_config_prefix != x ; then
++ gtk_config_args="$gtk_config_args --prefix=$gtk_config_prefix"
++ if test x${GTK_CONFIG+set} != xset ; then
++ GTK_CONFIG=$gtk_config_prefix/bin/gtk-config
++ fi
++ fi
++
++ AC_PATH_PROG(GTK_CONFIG, gtk-config, no)
++ min_gtk_version=ifelse([$1], ,0.99.7,$1)
++ AC_MSG_CHECKING(for GTK - version >= $min_gtk_version)
++ no_gtk=""
++ if test "$GTK_CONFIG" = "no" ; then
++ no_gtk=yes
++ else
++ GTK_CFLAGS=`$GTK_CONFIG $gtk_config_args --cflags`
++ GTK_LIBS=`$GTK_CONFIG $gtk_config_args --libs`
++ gtk_config_major_version=`$GTK_CONFIG $gtk_config_args --version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
++ gtk_config_minor_version=`$GTK_CONFIG $gtk_config_args --version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
++ gtk_config_micro_version=`$GTK_CONFIG $gtk_config_args --version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++ if test "x$enable_gtktest" = "xyes" ; then
++ ac_save_CFLAGS="$CFLAGS"
++ ac_save_LIBS="$LIBS"
++ CFLAGS="$CFLAGS $GTK_CFLAGS"
++ LIBS="$GTK_LIBS $LIBS"
++dnl
++dnl Now check if the installed GTK is sufficiently new. (Also sanity
++dnl checks the results of gtk-config to some extent
++dnl
++ rm -f conf.gtktest
++ AC_TRY_RUN([
++#include <gtk/gtk.h>
++#include <stdio.h>
++#include <stdlib.h>
++
++int
++main ()
++{
++ int major, minor, micro;
++ char *tmp_version;
++
++ system ("touch conf.gtktest");
++
++ /* HP/UX 9 (%@#!) writes to sscanf strings */
++ tmp_version = g_strdup("$min_gtk_version");
++ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
++ printf("%s, bad version string\n", "$min_gtk_version");
++ exit(1);
++ }
++
++ if ((gtk_major_version != $gtk_config_major_version) ||
++ (gtk_minor_version != $gtk_config_minor_version) ||
++ (gtk_micro_version != $gtk_config_micro_version))
++ {
++ printf("\n*** 'gtk-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
++ $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ printf ("*** was found! If gtk-config was correct, then it is best\n");
++ printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
++ printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
++ printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
++ printf("*** required on your system.\n");
++ printf("*** If gtk-config was wrong, set the environment variable GTK_CONFIG\n");
++ printf("*** to point to the correct copy of gtk-config, and remove the file config.cache\n");
++ printf("*** before re-running configure\n");
++ }
++#if defined (GTK_MAJOR_VERSION) && defined (GTK_MINOR_VERSION) && defined (GTK_MICRO_VERSION)
++ else if ((gtk_major_version != GTK_MAJOR_VERSION) ||
++ (gtk_minor_version != GTK_MINOR_VERSION) ||
++ (gtk_micro_version != GTK_MICRO_VERSION))
++ {
++ printf("*** GTK+ header files (version %d.%d.%d) do not match\n",
++ GTK_MAJOR_VERSION, GTK_MINOR_VERSION, GTK_MICRO_VERSION);
++ printf("*** library (version %d.%d.%d)\n",
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ }
++#endif /* defined (GTK_MAJOR_VERSION) ... */
++ else
++ {
++ if ((gtk_major_version > major) ||
++ ((gtk_major_version == major) && (gtk_minor_version > minor)) ||
++ ((gtk_major_version == major) && (gtk_minor_version == minor) && (gtk_micro_version >= micro)))
++ {
++ return 0;
++ }
++ else
++ {
++ printf("\n*** An old version of GTK+ (%d.%d.%d) was found.\n",
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ printf("*** You need a version of GTK+ newer than %d.%d.%d. The latest version of\n",
++ major, minor, micro);
++ printf("*** GTK+ is always available from ftp://ftp.gtk.org.\n");
++ printf("***\n");
++ printf("*** If you have already installed a sufficiently new version, this error\n");
++ printf("*** probably means that the wrong copy of the gtk-config shell script is\n");
++ printf("*** being found. The easiest way to fix this is to remove the old version\n");
++ printf("*** of GTK+, but you can also set the GTK_CONFIG environment to point to the\n");
++ printf("*** correct copy of gtk-config. (In this case, you will have to\n");
++ printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
++ printf("*** so that the correct libraries are found at run-time))\n");
++ }
++ }
++ return 1;
++}
++],, no_gtk=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
++ CFLAGS="$ac_save_CFLAGS"
++ LIBS="$ac_save_LIBS"
++ fi
++ fi
++ if test "x$no_gtk" = x ; then
++ AC_MSG_RESULT(yes)
++ ifelse([$2], , :, [$2])
++ else
++ AC_MSG_RESULT(no)
++ if test "$GTK_CONFIG" = "no" ; then
++ echo "*** The gtk-config script installed by GTK could not be found"
++ echo "*** If GTK was installed in PREFIX, make sure PREFIX/bin is in"
++ echo "*** your path, or set the GTK_CONFIG environment variable to the"
++ echo "*** full path to gtk-config."
++ else
++ if test -f conf.gtktest ; then
++ :
++ else
++ echo "*** Could not run GTK test program, checking why..."
++ CFLAGS="$CFLAGS $GTK_CFLAGS"
++ LIBS="$LIBS $GTK_LIBS"
++ AC_TRY_LINK([
++#include <gtk/gtk.h>
++#include <stdio.h>
++], [ return ((gtk_major_version) || (gtk_minor_version) || (gtk_micro_version)); ],
++ [ echo "*** The test program compiled, but did not run. This usually means"
++ echo "*** that the run-time linker is not finding GTK or finding the wrong"
++ echo "*** version of GTK. If it is not finding GTK, you'll need to set your"
++ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
++ echo "*** to the installed location Also, make sure you have run ldconfig if that"
++ echo "*** is required on your system"
++ echo "***"
++ echo "*** If you have an old version installed, it is best to remove it, although"
++ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"
++ echo "***"
++ echo "*** If you have a RedHat 5.0 system, you should remove the GTK package that"
++ echo "*** came with the system with the command"
++ echo "***"
++ echo "*** rpm --erase --nodeps gtk gtk-devel" ],
++ [ echo "*** The test program failed to compile or link. See the file config.log for the"
++ echo "*** exact error that occured. This usually means GTK was incorrectly installed"
++ echo "*** or that you have moved GTK since it was installed. In the latter case, you"
++ echo "*** may want to edit the gtk-config script: $GTK_CONFIG" ])
++ CFLAGS="$ac_save_CFLAGS"
++ LIBS="$ac_save_LIBS"
++ fi
++ fi
++ GTK_CFLAGS=""
++ GTK_LIBS=""
++ ifelse([$3], , :, [$3])
++ fi
++ AC_SUBST(GTK_CFLAGS)
++ AC_SUBST(GTK_LIBS)
++ rm -f conf.gtktest
++])
+Index: gutenprint-5.0.0-rc1/src/main/Makefile.am
+===================================================================
+--- gutenprint-5.0.0-rc1.orig/src/main/Makefile.am
++++ gutenprint-5.0.0-rc1/src/main/Makefile.am
+@@ -145,7 +145,7 @@ libgutenprint_la_SOURCES = \
+ $(libgutenprint_headers) \
+ $(libgutenprint_modules)
+
+-libgutenprint_la_LIBADD = $(GUTENPRINT_LIBDEPS)
++libgutenprint_la_LIBADD = $(GUTENPRINT_LIBDEPS) -lm
+ # Uncommment to build an unversioned library (version in soname)
+ #libgutenprint_version = -release $(GUTENPRINT_VERSION)
+ # Uncomment to build a versioned library
+Index: gutenprint-5.0.0-rc1/src/cups/Makefile.am
+===================================================================
+--- gutenprint-5.0.0-rc1.orig/src/cups/Makefile.am
++++ gutenprint-5.0.0-rc1/src/cups/Makefile.am
+@@ -77,11 +77,11 @@ epson_SOURCES = epson.c
+ epson_LDADD = $(CUPS_LIBS)
+
+ cups_genppd_@GUTENPRINT_MAJOR_VERSION@_@GUTENPRINT_MINOR_VERSION@_SOURCES = genppd.c
+-cups_genppd_@GUTENPRINT_MAJOR_VERSION@_@GUTENPRINT_MINOR_VERSION@_LDADD = $(CUPS_LIBS) $(GENPPD_LIBS) $(GUTENPRINT_LIBS)
++cups_genppd_@GUTENPRINT_MAJOR_VERSION@_@GUTENPRINT_MINOR_VERSION@_LDADD = $(CUPS_LIBS) $(GENPPD_LIBS) $(GUTENPRINT_LIBS) -lm
+ cups_genppd_@GUTENPRINT_MAJOR_VERSION@_@GUTENPRINT_MINOR_VERSION@_LDFLAGS = $(STATIC_LDOPTS)
+
+ rastertogutenprint_@GUTENPRINT_MAJOR_VERSION@_@GUTENPRINT_MINOR_VERSION@_SOURCES = rastertoprinter.c
+-rastertogutenprint_@GUTENPRINT_MAJOR_VERSION@_@GUTENPRINT_MINOR_VERSION@_LDADD = $(CUPS_LIBS) $(GUTENPRINT_LIBS)
++rastertogutenprint_@GUTENPRINT_MAJOR_VERSION@_@GUTENPRINT_MINOR_VERSION@_LDADD = $(CUPS_LIBS) $(GUTENPRINT_LIBS) -lm
+ rastertogutenprint_@GUTENPRINT_MAJOR_VERSION@_@GUTENPRINT_MINOR_VERSION@_LDFLAGS = $(STATIC_LDOPTS)
+
+ cups-genppdconfig.@GUTENPRINT_MAJOR_VERSION@.@GUTENPRINT_MINOR_VERSION@: $(top_builddir)/config.status cups-genppdconfig.in
diff --git a/media-gfx/gimp-print/gimp-print-5.0.0_rc1.ebuild b/media-gfx/gimp-print/gimp-print-5.0.0_rc1.ebuild
index b3102b50519a..04f7166c0022 100644
--- a/media-gfx/gimp-print/gimp-print-5.0.0_rc1.ebuild
+++ b/media-gfx/gimp-print/gimp-print-5.0.0_rc1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-5.0.0_rc1.ebuild,v 1.1 2005/11/02 23:52:51 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-5.0.0_rc1.ebuild,v 1.2 2006/01/04 09:28:18 flameeyes Exp $
-inherit flag-o-matic libtool
+inherit flag-o-matic libtool autotools
IUSE="cups foomaticdb gtk nls readline ppds"
@@ -13,7 +13,7 @@ HOMEPAGE="http://gimp-print.sourceforge.net"
KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64 ~ppc64"
SRC_URI="mirror://sourceforge/gimp-print/${MY_P}.tar.bz2"
-DEPEND="cups? ( >=net-print/cups-1.1.14 )
+RDEPEND="cups? ( >=net-print/cups-1.1.14 )
media-gfx/imagemagick
virtual/ghostscript
sys-libs/readline
@@ -21,6 +21,11 @@ DEPEND="cups? ( >=net-print/cups-1.1.14 )
dev-lang/perl
foomaticdb? ( net-print/foomatic-db-engine )"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool"
+
LICENSE="GPL-2"
SLOT="0"
@@ -28,26 +33,20 @@ S=${WORKDIR}/${MY_P}
append-flags -fno-inline-functions
-src_compile() {
- elibtoolize --reverse-deps
+src_unpack() {
+ unpack ${A}
+ cd ${S}
- use nls \
- && myconf="${myconf} --enable-nls" \
- || myconf="${myconf} --disable-nls"
+ epatch "${FILESDIR}/${P}-asneeded.patch"
- use readline \
- && myconf="${myconf} --with-readline" \
- || myconf="${myconf} --without-readline"
+ # get rid of the libtool.m4 file that's broken
+ rm -f ${S}/m4extra/libtool.m4
- use gtk \
- && myconf="${myconf} --enable-lexmarkutil" \
- || myconf="${myconf} --disable-lexmarkutil"
+ AT_M4DIR="m4 m4extra" eautoreconf
+}
- if use cups; then
- myconf="${myconf} --with-cups"
- else
- myconf="${myconf} --without-cups"
- fi
+src_compile() {
+ elibtoolize --reverse-deps
if use cups && use ppds; then
myconf="${myconf} --enable-cups-ppds --enable-cups-level3-ppds"
@@ -66,6 +65,10 @@ src_compile() {
--with-user-guide \
--with-samples \
--with-escputil \
+ $(use_enable nls) \
+ $(use_with readline) \
+ $(use_enable gtk lexmarkutil) \
+ $(use_with cups) \
$myconf || die
# IJS Patch