summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/graphviz')
-rw-r--r--media-gfx/graphviz/ChangeLog5
-rw-r--r--media-gfx/graphviz/graphviz-2.28.0.ebuild29
2 files changed, 19 insertions, 15 deletions
diff --git a/media-gfx/graphviz/ChangeLog b/media-gfx/graphviz/ChangeLog
index fd44f1d80c9d..49df436eeef2 100644
--- a/media-gfx/graphviz/ChangeLog
+++ b/media-gfx/graphviz/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/graphviz
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.271 2013/03/02 21:36:18 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.272 2013/03/10 18:06:53 mgorny Exp $
+
+ 10 Mar 2013; Michał Górny <mgorny@gentoo.org> graphviz-2.28.0.ebuild:
+ Convert to python-single-r1. Bug #457686.
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> graphviz-2.28.0.ebuild:
Move Qt dependencies to the new category
diff --git a/media-gfx/graphviz/graphviz-2.28.0.ebuild b/media-gfx/graphviz/graphviz-2.28.0.ebuild
index 9ddd4df4ce52..b415ebc7ed11 100644
--- a/media-gfx/graphviz/graphviz-2.28.0.ebuild
+++ b/media-gfx/graphviz/graphviz-2.28.0.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.28.0.ebuild,v 1.17 2013/03/02 21:36:18 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.28.0.ebuild,v 1.18 2013/03/10 18:06:53 mgorny Exp $
-EAPI=4
-PYTHON_DEPEND="python? 2"
+EAPI=5
-inherit eutils autotools multilib python flag-o-matic
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit autotools eutils flag-o-matic multilib python-single-r1
DESCRIPTION="Open Source Graph Visualization Software"
HOMEPAGE="http://www.graphviz.org/"
@@ -47,6 +48,7 @@ RDEPEND="
gtk? ( x11-libs/gtk+:2 )
gts? ( sci-libs/gts )
lasi? ( media-libs/lasi )
+ python? ( ${PYTHON_DEPS} )
qt4? (
dev-qt/qtcore:4
dev-qt/qtgui:4
@@ -60,7 +62,10 @@ DEPEND="${RDEPEND}
java? ( dev-lang/swig )
nls? ( >=sys-devel/gettext-0.14.5 )
perl? ( dev-lang/swig )
- python? ( dev-lang/swig )
+ python? (
+ dev-lang/swig
+ ${PYTHON_DEPS}
+ )
ruby? ( dev-lang/swig )
tcl? ( dev-lang/swig )"
REQUIRED_USE="!cairo? ( !X !gtk !postscript !lasi )"
@@ -125,10 +130,7 @@ REQUIRED_USE="!cairo? ( !X !gtk !postscript !lasi )"
# with flags enabled at configure time
pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
+ use python && python-single-r1_pkg_setup
}
src_prepare() {
@@ -237,15 +239,14 @@ src_install() {
use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
dodoc AUTHORS ChangeLog NEWS README
+
+ use python && python_optimize \
+ "${D}$(python_get_sitedir)" \
+ "${D}/usr/$(get_libdir)/graphviz/python"
}
pkg_postinst() {
# This actually works if --enable-ltdl is passed
# to configure
dot -c
- use python && python_mod_optimize gv.py
-}
-
-pkg_postrm() {
- use python && python_mod_cleanup gv.py
}