summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/povray')
-rw-r--r--media-gfx/povray/ChangeLog7
-rw-r--r--media-gfx/povray/files/povray-3.7.0_rc6-darwin-defaults.patch21
-rw-r--r--media-gfx/povray/povray-3.7.0_rc3.ebuild4
-rw-r--r--media-gfx/povray/povray-3.7.0_rc6.ebuild5
4 files changed, 33 insertions, 4 deletions
diff --git a/media-gfx/povray/ChangeLog b/media-gfx/povray/ChangeLog
index 6a0ca3ba4fd8..7f8173199ae6 100644
--- a/media-gfx/povray/ChangeLog
+++ b/media-gfx/povray/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/povray
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/ChangeLog,v 1.143 2013/03/04 19:08:37 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/ChangeLog,v 1.144 2013/03/05 01:34:02 ottxor Exp $
+
+ 05 Mar 2013; Christoph Junghans <ottxor@gentoo.org>
+ +files/povray-3.7.0_rc6-darwin-defaults.patch, povray-3.7.0_rc3.ebuild,
+ povray-3.7.0_rc6.ebuild:
+ added support for darwin
04 Mar 2013; Christoph Junghans <ottxor@gentoo.org>
-povray-3.7.0_rc5-r1.ebuild, povray-3.7.0_rc3.ebuild:
diff --git a/media-gfx/povray/files/povray-3.7.0_rc6-darwin-defaults.patch b/media-gfx/povray/files/povray-3.7.0_rc6-darwin-defaults.patch
new file mode 100644
index 000000000000..16e09c749b2e
--- /dev/null
+++ b/media-gfx/povray/files/povray-3.7.0_rc6-darwin-defaults.patch
@@ -0,0 +1,21 @@
+# Darwin does not support thread-local storage (__thread)
+# http://lists.apple.com/archives/xcode-users/2006/Jun/msg00551.html
+# so use default from boost thread
+
+# use lseek for lseek64
+# sys/types.h is needed because of uint
+
+--- povray-3.7.0.RC6/vfe/unix/syspovconfig.h.orig 2013-03-01 11:09:42.000000000 -0700
++++ povray-3.7.0.RC6/vfe/unix/syspovconfig.h 2013-03-01 11:07:14.000000000 -0700
+@@ -171,9 +171,7 @@
+ #define METADATA_PLATFORM_STRING BUILD_ARCH
+ #define METADATA_COMPILER_STRING COMPILER_VERSION
+
+-#define DECLARE_THREAD_LOCAL_PTR(ptrType, ptrName) __thread ptrType *ptrName
+-#define IMPLEMENT_THREAD_LOCAL_PTR(ptrType, ptrName, ignore) __thread ptrType *ptrName
+-#define GET_THREAD_LOCAL_PTR(ptrName) (ptrName)
+-#define SET_THREAD_LOCAL_PTR(ptrName, ptrValue) (ptrName = ptrValue)
++#define lseek64 lseek
++#include <sys/types.h>
+
+ #endif
diff --git a/media-gfx/povray/povray-3.7.0_rc3.ebuild b/media-gfx/povray/povray-3.7.0_rc3.ebuild
index 1047452359a4..e0256bbf881b 100644
--- a/media-gfx/povray/povray-3.7.0_rc3.ebuild
+++ b/media-gfx/povray/povray-3.7.0_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.7.0_rc3.ebuild,v 1.11 2013/03/04 19:08:37 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.7.0_rc3.ebuild,v 1.12 2013/03/05 01:34:02 ottxor Exp $
EAPI="3"
@@ -21,7 +21,7 @@ SRC_URI="http://www.povray.org/redirect/www.povray.org/beta/source/${PN}-${MY_PV
LICENSE="povlegal-3.6"
SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="debug openexr tiff X"
DEPEND="
diff --git a/media-gfx/povray/povray-3.7.0_rc6.ebuild b/media-gfx/povray/povray-3.7.0_rc6.ebuild
index 87e0352cc0f1..cc56c1d08dd7 100644
--- a/media-gfx/povray/povray-3.7.0_rc6.ebuild
+++ b/media-gfx/povray/povray-3.7.0_rc6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.7.0_rc6.ebuild,v 1.5 2013/03/02 00:49:41 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.7.0_rc6.ebuild,v 1.6 2013/03/05 01:34:02 ottxor Exp $
EAPI=4
@@ -47,6 +47,9 @@ src_prepare() {
"${FILESDIR}"/${PN}-3.7.0_rc5+boost-1.50.patch \
"${FILESDIR}"/${PN}-3.7.0_rc5-automagic.patch
+ [[ ${CHOST} == *-darwin* ]] && \
+ epatch "${FILESDIR}"/${PN}-3.7.0_rc6-darwin-defaults.patch
+
# Change some destination directories that cannot be adjusted via configure
sed \
-e 's:${povsysconfdir}/$PACKAGE/$VERSION_BASE:${povsysconfdir}/'${PN}':g' \