summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/rawstudio/rawstudio-1.1.ebuild')
-rw-r--r--media-gfx/rawstudio/rawstudio-1.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-gfx/rawstudio/rawstudio-1.1.ebuild b/media-gfx/rawstudio/rawstudio-1.1.ebuild
new file mode 100644
index 000000000000..23239e30bdc6
--- /dev/null
+++ b/media-gfx/rawstudio/rawstudio-1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawstudio/rawstudio-1.1.ebuild,v 1.1 2008/09/21 12:07:01 maekke Exp $
+
+inherit eutils
+
+DESCRIPTION="a program to read and manipulate raw images from digital cameras."
+HOMEPAGE="http://rawstudio.org"
+SRC_URI="http://${PN}.org/files/release/${P}.tar.gz"
+
+LICENSE="GPL-2 CCPL-Attribution-NoDerivs-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/jpeg
+ media-libs/tiff
+ >=x11-libs/gtk+-2.8
+ >=dev-libs/libxml2-2.4
+ media-libs/lcms
+ >=gnome-base/gconf-2
+ sys-apps/dbus"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-desktop-entry-and-pixmaps-directory.patch
+}
+
+src_compile() {
+ econf --disable-dependency-tracking
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}