summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/sane-backends/files/sane-backends-1.0.24-systemd_pkgconfig.patch')
-rw-r--r--media-gfx/sane-backends/files/sane-backends-1.0.24-systemd_pkgconfig.patch33
1 files changed, 23 insertions, 10 deletions
diff --git a/media-gfx/sane-backends/files/sane-backends-1.0.24-systemd_pkgconfig.patch b/media-gfx/sane-backends/files/sane-backends-1.0.24-systemd_pkgconfig.patch
index 2a75145ae4f4..2d36cfaeab56 100644
--- a/media-gfx/sane-backends/files/sane-backends-1.0.24-systemd_pkgconfig.patch
+++ b/media-gfx/sane-backends/files/sane-backends-1.0.24-systemd_pkgconfig.patch
@@ -1,24 +1,37 @@
diff --git a/configure.in b/configure.in
-index 7413646..2c05265 100644
+index 7413646..66828fc 100644
--- a/configure.in
+++ b/configure.in
-@@ -347,17 +347,11 @@ dnl fi
+@@ -347,21 +347,18 @@ dnl fi
AC_ARG_WITH(systemd,
AC_HELP_STRING([--with-systemd], [enable systemd support @<:@default=yes@:>@]))
if test "x$with_systemd" != xno ; then
- dnl added by llagendijk 12/7/2012 to detect systemd for saned
- $as_echo_n "Checking for systemd..."
- if test -e /usr/include/systemd/sd-daemon.h ; then
-+ PKG_CHECK_MODULES(SYSTEMD, [libsystemd libsystemd-daemon], have_systemd=yes, have_systemd=no)
-+ if test "x$have_systemd" = xyes; then
- AC_DEFINE(HAVE_SYSTEMD, 1, [Is /usr/include/systemd/sd-daemon.h available?])
+- AC_DEFINE(HAVE_SYSTEMD, 1, [Is /usr/include/systemd/sd-daemon.h available?])
- have_systemd="yes"
- SYSTEMD_LIBS=" -lsystemd-daemon"
- AC_SUBST(SYSTEMD_LIBS)
+- AC_SUBST(SYSTEMD_LIBS)
- $as_echo "yes"
- else
+- else
- have_systemd="no"
- $as_echo "no"
- if test "x$with_systemd" = xyes; then
- AC_MSG_ERROR([Systemd support was requested but systemd was not found])
- fi
+- if test "x$with_systemd" = xyes; then
+- AC_MSG_ERROR([Systemd support was requested but systemd was not found])
+- fi
++ PKG_CHECK_MODULES(SYSTEMD, [libsystemd], have_systemd=yes, have_systemd=no)
++ if test "x$have_systemd" = xno; then
++ PKG_CHECK_MODULES(SYSTEMD, [libsystemd-daemon], have_systemd=yes, have_systemd=no)
++ fi
++ if test "x$have_systemd" = xyes; then
++ AC_DEFINE(HAVE_SYSTEMD, 1, [Is /usr/include/systemd/sd-daemon.h available?])
++ AC_SUBST(SYSTEMD_LIBS)
++ else
++ if test "x$with_systemd" = xyes; then
++ AC_MSG_ERROR([Systemd support was requested but systemd was not found])
+ fi
++ fi
+ fi
+
+ dnl ***********