summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/fontconfig/fontconfig-2.3.2.ebuild')
-rw-r--r--media-libs/fontconfig/fontconfig-2.3.2.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/media-libs/fontconfig/fontconfig-2.3.2.ebuild b/media-libs/fontconfig/fontconfig-2.3.2.ebuild
deleted file mode 100644
index 5e8fd1838992..000000000000
--- a/media-libs/fontconfig/fontconfig-2.3.2.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.3.2.ebuild,v 1.4 2006/03/31 20:11:03 flameeyes Exp $
-
-inherit eutils libtool
-
-DESCRIPTION="A library for configuring and customizing font access"
-HOMEPAGE="http://fontconfig.org/"
-SRC_URI="http://fontconfig.org/release/${P}.tar.gz"
-
-LICENSE="fontconfig"
-SLOT="1.0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=">=media-libs/freetype-2.1.4
- >=dev-libs/expat-1.95.3"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- local PPREFIX="${FILESDIR}/patch/${PN}"
-
- # Add our local fontpaths (duh dont forget!)
- epatch ${PPREFIX}-2.2-local_fontdir-r1.patch
-
- elibtoolize
- epunt_cxx #74077
-}
-
-src_compile() {
- [ "${ARCH}" == "alpha" -a "${CC}" == "ccc" ] && \
- die "Dont compile fontconfig with ccc, it doesnt work very well"
-
- # disable docs only disables docs generation (!)
- econf --disable-docs \
- --with-docdir=/usr/share/doc/${PF} \
- --x-includes=/usr/X11R6/include \
- --x-libraries=/usr/X11R6/lib \
- --with-default-fonts=/usr/share/fonts || die
-
- # this triggers sandbox, we do this ourselves
- sed -i "s:fc-cache/fc-cache -f -v:sleep 0:" Makefile
-
- emake -j1 || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-
- insinto /etc/fonts
- doins ${S}/fonts.conf
- newins ${S}/fonts.conf fonts.conf.new
-
- cd ${S}
-
- newman fc-cache/fc-cache.man fc-cache.1
- newman fc-list/fc-list.man fc-list.1
- newman src/fontconfig.man fontconfig.3
- dodoc AUTHORS ChangeLog NEWS README
-}
-
-pkg_postinst() {
- # Changes should be made to /etc/fonts/local.conf, and as we had
- # too much problems with broken fonts.conf, we force update it ...
- # <azarah@gentoo.org> (11 Dec 2002)
- ewarn "Please make fontconfig related changes to /etc/fonts/local.conf,"
- ewarn "and NOT to /etc/fonts/fonts.conf, as it will be replaced!"
- mv -f ${ROOT}/etc/fonts/fonts.conf.new ${ROOT}/etc/fonts/fonts.conf
- rm -f ${ROOT}/etc/fonts/._cfg????_fonts.conf
-
- if [ "${ROOT}" = "/" ]
- then
- echo
- einfo "Creating font cache..."
- /usr/bin/fc-cache -f
- fi
-}