summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gluon/gluon-0.70.0.ebuild')
-rw-r--r--media-libs/gluon/gluon-0.70.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/gluon/gluon-0.70.0.ebuild b/media-libs/gluon/gluon-0.70.0.ebuild
new file mode 100644
index 000000000000..2196c18116d5
--- /dev/null
+++ b/media-libs/gluon/gluon-0.70.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gluon/gluon-0.70.0.ebuild,v 1.1 2010/06/06 21:02:19 jmbsvicetto Exp $
+
+EAPI=2
+
+OPENGL_REQUIRED="always"
+inherit kde4-base
+
+DESCRIPTION="Gluon is a Free and Open Source framework for creating and distributing games."
+HOMEPAGE="http://gluon.tuxfamily.org/"
+SRC_URI="http://gluon.gamingfreedom.org/sites/default/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+COMMON_DEPEND="
+ media-libs/glew
+ media-libs/libogg
+ media-libs/libsndfile
+ media-libs/libvorbis
+ media-libs/openal
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXrandr
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+ x11-proto/randrproto
+"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${PN}"
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ sed -i '/add_subdirectory(src)/s/^#//' "${S}"/CMakeLists.txt || die "couldn't re-enable main library"
+}