summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/imlib2/imlib2-1.2.0.007.ebuild')
-rw-r--r--media-libs/imlib2/imlib2-1.2.0.007.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/imlib2/imlib2-1.2.0.007.ebuild b/media-libs/imlib2/imlib2-1.2.0.007.ebuild
new file mode 100644
index 000000000000..56e0789ca78e
--- /dev/null
+++ b/media-libs/imlib2/imlib2-1.2.0.007.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.2.0.007.ebuild,v 1.1 2005/05/20 03:21:43 vapier Exp $
+
+EKEY_STATE=snap
+EHACKAUTOGEN=yes
+inherit enlightenment
+
+MY_P=${P/_/-}
+DESCRIPTION="Version 2 of an advanced replacement library for libraries like libXpm"
+HOMEPAGE="http://www.enlightenment.org/pages/imlib2.html"
+
+IUSE="X gif jpeg mmx png tiff"
+
+DEPEND="=media-libs/freetype-2*
+ gif? ( >=media-libs/giflib-4.1.0 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( >=media-libs/tiff-3.5.5 )
+ X? ( virtual/x11 )"
+
+src_unpack() {
+ enlightenment_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-x-lib.patch
+}
+
+src_compile() {
+ local mymmx=""
+ if [ "${ARCH}" == "amd64" ] ; then
+ mymmx="--disable-mmx"
+ else
+ mymmx="$(use_enable mmx)"
+ fi
+
+ export MY_ECONF="
+ ${mymmx} \
+ $(use_with X x) \
+ "
+ enlightenment_src_compile
+}
+
+src_install() {
+ enlightenment_src_install
+ docinto samples
+ dodoc demo/*.c
+}