summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libpng/libpng-1.2.7.ebuild')
-rw-r--r--media-libs/libpng/libpng-1.2.7.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/media-libs/libpng/libpng-1.2.7.ebuild b/media-libs/libpng/libpng-1.2.7.ebuild
index 2fc4bdd765d2..2c51a466bc82 100644
--- a/media-libs/libpng/libpng-1.2.7.ebuild
+++ b/media-libs/libpng/libpng-1.2.7.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.2.7.ebuild,v 1.3 2004/09/22 14:55:08 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.2.7.ebuild,v 1.4 2004/09/23 07:48:21 eradicator Exp $
+
+IUSE=""
inherit flag-o-matic eutils gcc
@@ -10,8 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="as-is"
SLOT="1.2"
-KEYWORDS="x86 ~ppc ~sparc ~arm ~hppa ~amd64 ~alpha ~mips ~macos ~ppc-macos"
-IUSE=""
+KEYWORDS="x86 ~ppc ~sparc ~arm ~hppa amd64 ~alpha ~mips ~macos ~ppc-macos"
DEPEND="sys-libs/zlib"
@@ -28,14 +29,14 @@ src_unpack() {
if use macos || use ppc-macos ; then
epatch "${FILESDIR}/macos.patch" # implements strnlen
sed \
- -e "s:ZLIBLIB=.*:ZLIBLIB=/usr/lib:" \
+ -e "s:ZLIBLIB=.*:ZLIBLIB=/usr/$(get_libdir):" \
-e "s:ZLIBINC=.*:ZLIBINC=/usr/include:" \
-e "s:-O3:${CFLAGS}:" \
-e "s:prefix=/usr/local:prefix=/usr:" \
scripts/makefile.darwin > Makefile
else
sed \
- -e "s:ZLIBLIB=.*:ZLIBLIB=/usr/lib:" \
+ -e "s:ZLIBLIB=.*:ZLIBLIB=/usr/$(get_libdir):" \
-e "s:ZLIBINC=.*:ZLIBINC=/usr/include:" \
-e "s:-O3:${CFLAGS}:" \
-e "s:prefix=/usr/local:prefix=/usr:" \
@@ -52,15 +53,15 @@ src_compile() {
}
src_install() {
- dodir /usr/{include,lib} /usr/share/man
- einstall MANPATH="${D}/usr/share/man" || die
+ dodir /usr/include /usr/$(get_libdir) /usr/share/man
+ make DESTDIR="${D}" MANPATH="/usr/share/man" LIBPATH="/usr/$(get_libdir)" install || die
doman libpng.3 libpngpf.3 png.5
dodoc ANNOUNCE CHANGES KNOWNBUG README TODO Y2KINFO
}
pkg_postinst() {
# the libpng authors really screwed around between 1.2.1 and 1.2.3
- if [ -f "${ROOT}/usr/lib/libpng.so.3.1.2.1" ] ; then
- rm "${ROOT}/usr/lib/libpng.so.3.1.2.1"
+ if [ -f "${ROOT}/usr/$(get_libdir)/libpng.so.3.1.2.1" ] ; then
+ rm "${ROOT}/usr/$(get_libdir)/libpng.so.3.1.2.1"
fi
}