summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/mesa/mesa-10.0.3.ebuild')
-rw-r--r--media-libs/mesa/mesa-10.0.3.ebuild26
1 files changed, 25 insertions, 1 deletions
diff --git a/media-libs/mesa/mesa-10.0.3.ebuild b/media-libs/mesa/mesa-10.0.3.ebuild
index 827065f493db..c2ec62c2aa88 100644
--- a/media-libs/mesa/mesa-10.0.3.ebuild
+++ b/media-libs/mesa/mesa-10.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-10.0.3.ebuild,v 1.1 2014/02/03 21:44:45 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-10.0.3.ebuild,v 1.2 2014/02/24 19:42:05 chithanh Exp $
EAPI=5
@@ -80,6 +80,7 @@ REQUIRED_USE="
video_cards_r600? ( gallium )
video_cards_radeonsi? ( gallium llvm )
video_cards_vmware? ( gallium )
+ ${PYTHON_REQUIRED_USE}
"
LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.49"
@@ -100,6 +101,23 @@ RDEPEND="
x11-libs/libXext[${MULTILIB_USEDEP}]
x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
>=x11-libs/libxcb-1.9.2[${MULTILIB_USEDEP}]
+ llvm? (
+ video_cards_radeonsi? ( || (
+ dev-libs/elfutils[${MULTILIB_USEDEP}]
+ dev-libs/libelf[${MULTILIB_USEDEP}]
+ ) )
+ video_cards_r600? ( || (
+ dev-libs/elfutils[${MULTILIB_USEDEP}]
+ dev-libs/libelf[${MULTILIB_USEDEP}]
+ ) )
+ !video_cards_r600? (
+ video_cards_radeon? ( || (
+ dev-libs/elfutils[${MULTILIB_USEDEP}]
+ dev-libs/libelf[${MULTILIB_USEDEP}]
+ ) )
+ )
+ llvm-shared-libs? ( >=sys-devel/llvm-2.9[${MULTILIB_USEDEP}] )
+ )
opencl? (
app-admin/eselect-opencl
dev-libs/libclc
@@ -162,6 +180,12 @@ pkg_setup() {
# workaround toc-issue wrt #386545
use ppc64 && append-flags -mminimal-toc
+ # warning message for bug 459306
+ if use llvm && has_version sys-devel/llvm[!debug=]; then
+ ewarn "Mismatch between debug USE flags in media-libs/mesa and sys-devel/llvm"
+ ewarn "detected! This can cause problems. For details, see bug 459306."
+ fi
+
python-any-r1_pkg_setup
}