summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/ChangeLog5
-rw-r--r--media-libs/mesa/mesa-6.4.2-r1.ebuild6
2 files changed, 8 insertions, 3 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 3968f130b7e5..df7334aca0aa 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/mesa
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.69 2006/02/16 04:30:02 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.70 2006/02/28 01:28:43 spyderous Exp $
+
+ 28 Feb 2006; Donnie Berkholz <spyderous@gentoo.org>; mesa-6.4.2-r1.ebuild:
+ Make USE=debug work more nicely with FEATURES=splitdebug.
*mesa-6.4.2-r1 (16 Feb 2006)
diff --git a/media-libs/mesa/mesa-6.4.2-r1.ebuild b/media-libs/mesa/mesa-6.4.2-r1.ebuild
index f255f57b0134..12e89965a44d 100644
--- a/media-libs/mesa/mesa-6.4.2-r1.ebuild
+++ b/media-libs/mesa/mesa-6.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.4.2-r1.ebuild,v 1.1 2006/02/16 04:30:02 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.4.2-r1.ebuild,v 1.2 2006/02/28 01:28:43 spyderous Exp $
inherit eutils toolchain-funcs multilib flag-o-matic
@@ -55,7 +55,9 @@ S="${WORKDIR}/${MY_P}"
# Think about: ggi, svga, fbcon, no-X configs
if use debug; then
- RESTRICT="${RESTRICT} nostrip"
+ if ! has splitdebug ${FEATURES}; then
+ RESTRICT="${RESTRICT} nostrip"
+ fi
fi
pkg_setup() {