summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-live')
-rw-r--r--media-plugins/vdr-live/ChangeLog9
-rw-r--r--media-plugins/vdr-live/vdr-live-0.2.0_p20120325-r1.ebuild110
-rw-r--r--media-plugins/vdr-live/vdr-live-0.3.0-r1.ebuild96
-rw-r--r--media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild (renamed from media-plugins/vdr-live/vdr-live-0.3.0_p20130504.ebuild)10
4 files changed, 13 insertions, 212 deletions
diff --git a/media-plugins/vdr-live/ChangeLog b/media-plugins/vdr-live/ChangeLog
index d67cf35f7cd9..a11b96d61250 100644
--- a/media-plugins/vdr-live/ChangeLog
+++ b/media-plugins/vdr-live/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/vdr-live
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/ChangeLog,v 1.43 2014/01/08 13:20:17 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/ChangeLog,v 1.44 2014/01/24 05:04:56 hd_brummy Exp $
+
+*vdr-live-0.3.0_p20130504-r1 (24 Jan 2014)
+
+ 24 Jan 2014; Joerg Bornkessel <hd_brummy@gentoo.org>
+ -vdr-live-0.2.0_p20120325-r1.ebuild, -vdr-live-0.3.0-r1.ebuild,
+ -vdr-live-0.3.0_p20130504.ebuild, +vdr-live-0.3.0_p20130504-r1.ebuild:
+ clenup old; fixed depend to latest tntnet/cxxtools
08 Jan 2014; Joerg Bornkessel <hd_brummy@gentoo.org> vdr-live-0.2.0.ebuild:
converted to use vdr-plugin-2.eclass
diff --git a/media-plugins/vdr-live/vdr-live-0.2.0_p20120325-r1.ebuild b/media-plugins/vdr-live/vdr-live-0.2.0_p20120325-r1.ebuild
deleted file mode 100644
index e4708704c130..000000000000
--- a/media-plugins/vdr-live/vdr-live-0.2.0_p20120325-r1.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.2.0_p20120325-r1.ebuild,v 1.2 2012/10/11 18:01:19 idl0r Exp $
-
-EAPI="4"
-
-inherit vdr-plugin-2 ssl-cert toolchain-funcs
-
-DESCRIPTION="VDR Plugin: Web Access To Settings"
-HOMEPAGE="http://live.vdr-developer.org"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="pcre ssl"
-
-DEPEND="media-video/vdr
- >=dev-libs/tntnet-2.0[ssl=,sdk]
- >=dev-libs/cxxtools-2.0
- pcre? ( >=dev-libs/libpcre-8.12[cxx] )"
-RDEPEND="${DEPEND}"
-
-VDR_CONFD_FILE="${FILESDIR}/confd-0.2"
-VDR_RCADDON_FILE="${FILESDIR}/rc-addon-0.2.sh"
-
-KEEP_I18NOBJECT="yes"
-
-# Damn vdr.eclass overrides $S...
-S="${WORKDIR}/${P}"
-
-make_live_cert() {
- # TODO: still true?
- # ssl-cert eclass creates a "invalid" cert, create our own one
- local base=$(get_base 1)
- local keydir="/etc/vdr/plugins/live"
-
- SSL_ORGANIZATION="${SSL_ORGANIZATION:-VDR Plugin Live}"
- SSL_COMMONNAME="${SSL_COMMONNAME:-`hostname -f`}"
-
- echo
- gen_cnf || return 1
- echo
- gen_key 1 || return 1
- gen_csr 1 || return 1
- gen_crt 1 || return 1
- echo
-
- install -d "${ROOT}${keydir}"
- install -m0400 "${base}.key" "${ROOT}${keydir}/live-key.pem"
- install -m0444 "${base}.crt" "${ROOT}${keydir}/live.pem"
- chown vdr:vdr "${ROOT}"/etc/vdr/plugins/live/live{,-key}.pem
-}
-
-pkg_setup() {
- vdr-plugin-2_pkg_setup
-
- tc-export CXX AR
-}
-
-src_prepare() {
- vdr-plugin-2_src_prepare
-
- if ! use pcre; then
- sed -i "s:^HAVE_LIBPCRECPP:#HAVE_LIBPCRECPP:" Makefile || die
- fi
-
- if ! has_version ">=media-video/vdr-1.7.13"; then
- sed -i "s:-include \$(VDRDIR)/Make.global:#-include \$(VDRDIR)/Make.global:" Makefile || die
- fi
-
- epatch "${FILESDIR}/vdr-1.7.28-compatibility.patch"
- epatch "${FILESDIR}/vdr-live_pcre.patch"
-}
-
-src_install() {
- vdr-plugin-2_src_install
-
- insinto /etc/vdr/plugins/live
- doins -r live/*
-
- fowners -R vdr:vdr /etc/vdr/plugins/live
-}
-
-pkg_postinst() {
- vdr-plugin-2_pkg_postinst
-
- elog "To be able to use all functions of vdr-live"
- elog "you should emerge and enable"
- elog "media-plugins/vdr-epgsearch to search the EPG,"
- elog "media-plugins/vdr-streamdev for Live-TV streaming"
-
- elog "The default username/password is:"
- elog "\tadmin:live"
-
- if use ssl ; then
- if path_exists -a "${ROOT}"/etc/vdr/plugins/live/live.pem; then
- einfo "found an existing SSL cert, to create a new SSL cert, run:"
- einfo ""
- einfo "emerge --config ${PN}"
- else
- einfo "No SSL cert found, creating a default one now"
- make_live_cert
- fi
- fi
-}
-
-pkg_config() {
- make_live_cert
-}
diff --git a/media-plugins/vdr-live/vdr-live-0.3.0-r1.ebuild b/media-plugins/vdr-live/vdr-live-0.3.0-r1.ebuild
deleted file mode 100644
index 2d0b7e22fe89..000000000000
--- a/media-plugins/vdr-live/vdr-live-0.3.0-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.3.0-r1.ebuild,v 1.1 2013/04/07 18:20:39 hd_brummy Exp $
-
-EAPI="5"
-
-inherit vdr-plugin-2 ssl-cert
-
-DESCRIPTION="VDR Plugin: Web Access To Settings"
-HOMEPAGE="http://live.vdr-developer.org"
-SRC_URI="http://live.vdr-developer.org/downloads/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="pcre ssl"
-
-DEPEND="media-video/vdr
- >=dev-libs/tntnet-2.0[ssl=,sdk]
- >=dev-libs/cxxtools-2.0
- pcre? ( >=dev-libs/libpcre-8.12[cxx] )"
-RDEPEND="${DEPEND}"
-
-VDR_CONFD_FILE="${FILESDIR}/confd-0.2"
-VDR_RCADDON_FILE="${FILESDIR}/rc-addon-0.2.sh"
-
-KEEP_I18NOBJECT="yes"
-
-make_live_cert() {
- # TODO: still true?
- # ssl-cert eclass creates a "invalid" cert, create our own one
- local base=$(get_base 1)
- local keydir="/etc/vdr/plugins/live"
-
- SSL_ORGANIZATION="${SSL_ORGANIZATION:-VDR Plugin Live}"
- SSL_COMMONNAME="${SSL_COMMONNAME:-`hostname -f`}"
-
- echo
- gen_cnf || return 1
- echo
- gen_key 1 || return 1
- gen_csr 1 || return 1
- gen_crt 1 || return 1
- echo
-
- install -d "${ROOT}${keydir}"
- install -m0400 "${base}.key" "${ROOT}${keydir}/live-key.pem"
- install -m0444 "${base}.crt" "${ROOT}${keydir}/live.pem"
- chown vdr:vdr "${ROOT}"/etc/vdr/plugins/live/live{,-key}.pem
-}
-
-src_prepare() {
- # remove untranslated language files
- rm "${S}"/po/{ca_ES,da_DK,el_GR,et_EE,hr_HR,hu_HU,nl_NL,nn_NO,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
-
- vdr-plugin-2_src_prepare
-
- if ! use pcre; then
- sed -i "s:^HAVE_LIBPCRECPP:#HAVE_LIBPCRECPP:" Makefile || die
- fi
-}
-
-src_install() {
- vdr-plugin-2_src_install
-
- insinto /usr/share/vdr/plugins/live
- doins -r live/*
-
- fowners -R vdr:vdr /usr/share/vdr/plugins/live
-}
-
-pkg_postinst() {
- vdr-plugin-2_pkg_postinst
-
- elog "To be able to use all functions of vdr-live"
- elog "you should emerge and enable"
- elog "media-plugins/vdr-epgsearch to search the EPG,"
- elog "media-plugins/vdr-streamdev for Live-TV streaming"
-
- elog "The default username/password is:"
- elog "\tadmin:live"
-
- if use ssl ; then
- if path_exists -a "${ROOT}"/etc/vdr/plugins/live/live.pem; then
- einfo "found an existing SSL cert, to create a new SSL cert, run:\n"
- einfo "emerge --config ${PN}"
- else
- einfo "No SSL cert found, creating a default one now"
- make_live_cert
- fi
- fi
-}
-
-pkg_config() {
- make_live_cert
-}
diff --git a/media-plugins/vdr-live/vdr-live-0.3.0_p20130504.ebuild b/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild
index a115bdf80d40..4e97acefc9b3 100644
--- a/media-plugins/vdr-live/vdr-live-0.3.0_p20130504.ebuild
+++ b/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.3.0_p20130504.ebuild,v 1.2 2013/10/23 02:11:45 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild,v 1.1 2014/01/24 05:04:56 hd_brummy Exp $
-EAPI="5"
+EAPI=5
inherit vdr-plugin-2 ssl-cert
@@ -17,8 +17,8 @@ KEYWORDS="~amd64 ~x86"
IUSE="pcre ssl"
DEPEND="media-video/vdr
- >=dev-libs/tntnet-2.0[ssl=,sdk]
- >=dev-libs/cxxtools-2.0
+ >=dev-libs/tntnet-2.2.1[ssl=]
+ >=dev-libs/cxxtools-2.2.1
pcre? ( >=dev-libs/libpcre-8.12[cxx] )"
RDEPEND="${DEPEND}"