summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mpg321/mpg321-0.2.10-r3.ebuild')
-rw-r--r--media-sound/mpg321/mpg321-0.2.10-r3.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/media-sound/mpg321/mpg321-0.2.10-r3.ebuild b/media-sound/mpg321/mpg321-0.2.10-r3.ebuild
index 5345849accf5..18446d986e52 100644
--- a/media-sound/mpg321/mpg321-0.2.10-r3.ebuild
+++ b/media-sound/mpg321/mpg321-0.2.10-r3.ebuild
@@ -1,29 +1,27 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/mpg321-0.2.10-r3.ebuild,v 1.10 2008/05/18 14:33:48 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/mpg321-0.2.10-r3.ebuild,v 1.11 2008/05/18 14:51:36 drac Exp $
inherit eutils
-IUSE=""
-
DESCRIPTION="Free MP3 player, drop-in replacement for mpg123"
+HOMEPAGE="http://sourceforge.net/projects/mpg321"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://sourceforge.net/projects/mpg321/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 -mips ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
DEPEND="media-libs/libmad
media-libs/libid3tag
- >=media-libs/libao-0.8.0"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="alpha ~amd64 -mips ppc ppc64 sparc x86 ~x86-fbsd"
+ media-libs/libao"
src_unpack() {
unpack ${A}
cd "${S}"
-
- # fix file descriptors leak (from Debian?)
- epatch "${FILESDIR}"/${P}.diff
+ # from debian?
+ epatch "${FILESDIR}"/${P}-file-descriptors-leak.patch
# provide an User-Agent when requesting via HTTP
# By Frank Ruell, in FreeBSD PR 84898
epatch "${FILESDIR}"/${P}-useragent.patch
@@ -31,12 +29,12 @@ src_unpack() {
src_compile() {
# disabling the symlink here and doing it in postinst is better for GRP
- econf --disable-mpg123-symlink || die
- emake || die
+ econf --disable-mpg123-symlink
+ emake || die "emake failed."
}
src_install () {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die "emake install failed."
dodoc AUTHORS BUGS ChangeLog HACKING NEWS README README.remote THANKS TODO
}