summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/peercast/peercast-0.1217.ebuild')
-rw-r--r--media-sound/peercast/peercast-0.1217.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/media-sound/peercast/peercast-0.1217.ebuild b/media-sound/peercast/peercast-0.1217.ebuild
new file mode 100644
index 000000000000..2d5d98ef58e8
--- /dev/null
+++ b/media-sound/peercast/peercast-0.1217.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/peercast/peercast-0.1217.ebuild,v 1.1 2006/03/09 18:40:58 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+IUSE=""
+
+S=${WORKDIR}
+
+DESCRIPTION="A client and server for Peercast P2P-radio network"
+HOMEPAGE="http://www.peercast.org"
+
+SRC_URI="http://www.peercast.org/src/${P}-src.tgz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}/${PN}-0.1216-makefile.patch"
+ epatch "${FILESDIR}/${PN}-0.1216-amd64.patch"
+}
+
+src_compile() {
+ append-ldflags -pthread
+
+ cd ${S}/ui/linux
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" AR="$(tc-getAR)" \
+ LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ cd ${S}/ui/linux
+
+ exeinto /usr/sbin
+ newexe "${FILESDIR}/peercast.wrapper.sh" peercast
+
+ exeinto /usr/libexec
+ doexe peercast
+
+ dodir /usr/share/peercast
+ cd ${S}/ui
+ cp -R html ${D}/usr/share/peercast/
+
+ newinitd "${FILESDIR}/peercast.init.gpl" peercast
+}
+
+pkg_postinst() {
+ einfo "Start Peercast with '/etc/init.d/peercast start' and point your"
+ einfo "webbrowser to 'http://localhost:7144' to start using Peercast."
+ einfo
+ einfo "You can also run 'rc-update add peercast default' to make Peercast"
+ einfo "start at boot."
+}