summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/phonon')
-rw-r--r--media-sound/phonon/ChangeLog6
-rw-r--r--media-sound/phonon/phonon-4.4_pre20090520.ebuild58
2 files changed, 63 insertions, 1 deletions
diff --git a/media-sound/phonon/ChangeLog b/media-sound/phonon/ChangeLog
index b84fdc4b8d4b..c778ccf32935 100644
--- a/media-sound/phonon/ChangeLog
+++ b/media-sound/phonon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/phonon
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/phonon/ChangeLog,v 1.31 2009/12/04 16:04:17 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/phonon/ChangeLog,v 1.32 2009/12/04 16:08:21 scarabeus Exp $
+
+ 04 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +phonon-4.4_pre20090520.ebuild:
+ Introduce back the latest stable. Sorry for mess.
04 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org> phonon-4.3.80.ebuild:
Drop weird src_unpack.
diff --git a/media-sound/phonon/phonon-4.4_pre20090520.ebuild b/media-sound/phonon/phonon-4.4_pre20090520.ebuild
new file mode 100644
index 000000000000..5500bf079590
--- /dev/null
+++ b/media-sound/phonon/phonon-4.4_pre20090520.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/phonon/phonon-4.4_pre20090520.ebuild,v 1.9 2009/12/04 16:08:21 scarabeus Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="KDE multimedia API"
+HOMEPAGE="http://phonon.kde.org"
+SRC_URI="http://dev.gentooexperimental.org/~alexxy/kde/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="debug gstreamer +xcb +xine"
+
+RDEPEND="
+ !kde-base/phonon-xine
+ !x11-libs/qt-phonon:4
+ >=x11-libs/qt-test-4.4.0:4
+ >=x11-libs/qt-dbus-4.4.0:4
+ >=x11-libs/qt-gui-4.4.0:4
+ >=x11-libs/qt-opengl-4.4.0:4
+ gstreamer? (
+ media-libs/gstreamer
+ media-libs/gst-plugins-base
+ )
+ xine? (
+ >=media-libs/xine-lib-1.1.15-r1[xcb?]
+ xcb? ( x11-libs/libxcb )
+ )
+"
+DEPEND="${RDEPEND}
+ >=kde-base/automoc-0.9.87
+"
+
+pkg_setup() {
+ if use !xine && use !gstreamer; then
+ die "you must at least select one backend for phonon"
+ fi
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with gstreamer GStreamer)
+ $(cmake-utils_use_with gstreamer GStreamerPlugins)
+ $(cmake-utils_use_with xine)"
+
+ if use xine; then
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with xcb)"
+ else
+ sed -i -e '/xine/d' CMakeLists.txt || die "sed failed"
+ fi
+
+ cmake-utils_src_configure
+}