summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog10
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-3.0-daap-schema.patch44
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-3.0-gdbus-return-value.patch50
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-3.0-rbzeitgeist-python3.patch85
-rw-r--r--media-sound/rhythmbox/rhythmbox-3.0-r1.ebuild158
-rw-r--r--media-sound/rhythmbox/rhythmbox-3.0.1.ebuild7
6 files changed, 15 insertions, 339 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index 9af0e36063ba..fddfc9e5ed45 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.248 2013/10/15 19:22:33 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.249 2013/10/19 13:57:13 pacho Exp $
+
+ 19 Oct 2013; Pacho Ramos <pacho@gentoo.org>
+ -files/rhythmbox-3.0-daap-schema.patch,
+ -files/rhythmbox-3.0-gdbus-return-value.patch,
+ -files/rhythmbox-3.0-rbzeitgeist-python3.patch, -rhythmbox-3.0-r1.ebuild,
+ rhythmbox-3.0.1.ebuild:
+ Let people emerge this by default (#472932), reconsider when it starts to
+ support another implementation. Drop old.
*rhythmbox-3.0.1 (15 Oct 2013)
diff --git a/media-sound/rhythmbox/files/rhythmbox-3.0-daap-schema.patch b/media-sound/rhythmbox/files/rhythmbox-3.0-daap-schema.patch
deleted file mode 100644
index ee3e8e95f3a1..000000000000
--- a/media-sound/rhythmbox/files/rhythmbox-3.0-daap-schema.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From c2a119fb7ec2bb6011c2998a401609dd426b0ce2 Mon Sep 17 00:00:00 2001
-From: David King <amigadave@amigadave.com>
-Date: Fri, 20 Sep 2013 17:52:49 +0100
-Subject: [PATCH] daap: Correctly fetch child schema
-
-https://bugzilla.gnome.org/show_bug.cgi?id=708476
----
- plugins/daap/rb-daap-source.c | 5 +----
- 1 file changed, 1 insertion(+), 4 deletions(-)
-
-diff --git a/plugins/daap/rb-daap-source.c b/plugins/daap/rb-daap-source.c
-index b605185..d4a173b 100644
---- a/plugins/daap/rb-daap-source.c
-+++ b/plugins/daap/rb-daap-source.c
-@@ -612,7 +612,6 @@ rb_daap_source_connection_cb (DMAPConnection *connection,
- {
- RBDAAPSource *daap_source = RB_DAAP_SOURCE (source);
- RBShell *shell = NULL;
-- GSettings *plugin_settings;
- GSettings *settings;
- GSList *playlists;
- GSList *l;
-@@ -637,9 +636,8 @@ rb_daap_source_connection_cb (DMAPConnection *connection,
- g_object_get (daap_source,
- "shell", &shell,
- "entry-type", &entry_type,
-- "settings", &plugin_settings,
-+ "settings", &settings,
- NULL);
-- settings = g_settings_get_child (plugin_settings, "source");
- playlists = dmap_connection_get_playlists (DMAP_CONNECTION (daap_source->priv->connection));
- for (l = playlists; l != NULL; l = g_slist_next (l)) {
- DMAPPlaylist *playlist = l->data;
-@@ -654,7 +652,6 @@ rb_daap_source_connection_cb (DMAPConnection *connection,
- }
-
- g_object_unref (settings);
-- g_object_unref (plugin_settings);
- g_object_unref (shell);
- g_object_unref (entry_type);
- }
---
-1.8.3.1
-
diff --git a/media-sound/rhythmbox/files/rhythmbox-3.0-gdbus-return-value.patch b/media-sound/rhythmbox/files/rhythmbox-3.0-gdbus-return-value.patch
deleted file mode 100644
index 3b8723b9d15f..000000000000
--- a/media-sound/rhythmbox/files/rhythmbox-3.0-gdbus-return-value.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 76540fdaa7baf56b01d8d269cbe482b1dbc58f09 Mon Sep 17 00:00:00 2001
-From: Jonathan Matthew <jonathan@d14n.org>
-Date: Fri, 13 Sep 2013 12:19:13 +0000
-Subject: metadata: GDBusServer new-connection signal needs a return value
-
-Turns out this is kind of important and has been working mostly by
-luck until now. When compiled with gcc's -fstack-protector-strong,
-we ended up returning 0, which in this case means that the connection
-isn't interesting, so it stops processing messages on it.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=706470
----
-diff --git a/metadata/rb-metadata-dbus-service.c b/metadata/rb-metadata-dbus-service.c
-index cb29d33..8280b2c 100644
---- a/metadata/rb-metadata-dbus-service.c
-+++ b/metadata/rb-metadata-dbus-service.c
-@@ -220,7 +220,7 @@ connection_closed_cb (GDBusConnection *connection,
- svc->connection = NULL;
- }
-
--static void
-+static gboolean
- new_connection_cb (GDBusServer *server,
- GDBusConnection *connection,
- ServiceData *svc)
-@@ -231,7 +231,7 @@ new_connection_cb (GDBusServer *server,
- /* don't allow more than one connection at a time */
- if (svc->connection) {
- rb_debug ("metadata service already has a client. go away.");
-- return;
-+ return FALSE;
- }
- g_dbus_connection_register_object (connection,
- RB_METADATA_DBUS_OBJECT_PATH,
-@@ -243,11 +243,13 @@ new_connection_cb (GDBusServer *server,
- if (error != NULL) {
- rb_debug ("unable to register metadata object: %s", error->message);
- g_clear_error (&error);
-+ return FALSE;
- } else {
- svc->connection = g_object_ref (connection);
- g_signal_connect (connection, "closed", G_CALLBACK (connection_closed_cb), svc);
-
- g_dbus_connection_set_exit_on_close (connection, (svc->external == FALSE));
-+ return TRUE;
- }
- }
-
---
-cgit v0.9.2
diff --git a/media-sound/rhythmbox/files/rhythmbox-3.0-rbzeitgeist-python3.patch b/media-sound/rhythmbox/files/rhythmbox-3.0-rbzeitgeist-python3.patch
deleted file mode 100644
index 4dd07d832ebe..000000000000
--- a/media-sound/rhythmbox/files/rhythmbox-3.0-rbzeitgeist-python3.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-From 693b013c02d54522e54ad15e980b5f46539888ec Mon Sep 17 00:00:00 2001
-From: Nirbheek Chauhan <nirbheek.chauhan@collabora.co.uk>
-Date: Sat, 14 Sep 2013 01:47:52 +0530
-Subject: [PATCH] plugins/rbzeitgeist: Port to Python3
-
----
- plugins/rbzeitgeist/rbzeitgeist.py | 24 ++++++++++++------------
- 1 file changed, 12 insertions(+), 12 deletions(-)
-
-diff --git a/plugins/rbzeitgeist/rbzeitgeist.py b/plugins/rbzeitgeist/rbzeitgeist.py
-index 984fd5b..a3a2630 100644
---- a/plugins/rbzeitgeist/rbzeitgeist.py
-+++ b/plugins/rbzeitgeist/rbzeitgeist.py
-@@ -37,8 +37,8 @@ from zeitgeist.datamodel import Event, Subject, Interpretation, Manifestation
-
- try:
- IFACE = ZeitgeistClient()
--except RuntimeError, e:
-- print "Unable to connect to Zeitgeist, won't send events. Reason: '%s'" %e
-+except RuntimeError as e:
-+ print("Unable to connect to Zeitgeist, won't send events. Reason: '{0}'".format(e))
- IFACE = None
-
- class ZeitgeistPlugin(GObject.Object, Peas.Activatable):
-@@ -46,12 +46,12 @@ class ZeitgeistPlugin(GObject.Object, Peas.Activatable):
- object = GObject.property(type=GObject.Object)
-
- def __init__(self):
-- GObject.Object.__init__(self)
-+ GObject.Object.__init__(self)
-
- def do_activate(self):
-- print "Loading Zeitgeist plugin..."
-+ print("Loading Zeitgeist plugin...")
- if IFACE is not None:
-- shell = self.object
-+ shell = self.object
- shell_player = shell.props.shell_player
- self.__psc_id = shell_player.connect("playing-song-changed", self.playing_song_changed)
-
-@@ -109,7 +109,7 @@ class ZeitgeistPlugin(GObject.Object, Peas.Activatable):
- idle, it means there are no more signals scheduled, so we
- will have already received the eos if it was coming.
- """
-- shell = self.object
-+ shell = self.object
- db = shell.props.db
- GLib.idle_add(self.send_to_zeitgeist, db, entry, event_type)
-
-@@ -131,16 +131,16 @@ class ZeitgeistPlugin(GObject.Object, Peas.Activatable):
-
- subject = Subject.new_for_values(
- uri=song["location"],
-- interpretation=unicode(Interpretation.AUDIO),
-- manifestation=unicode(Manifestation.FILE_DATA_OBJECT),
-+ interpretation=str(Interpretation.AUDIO),
-+ manifestation=str(Manifestation.FILE_DATA_OBJECT),
- origin=song["location"].rpartition("/")[0],
- mimetype=uri_mimetype,
- text=" - ".join([song["title"], song["artist"], song["album"]])
- )
- event = Event.new_for_values(
- timestamp=int(time.time()*1000),
-- interpretation=unicode(event_type),
-- manifestation=unicode(manifest),
-+ interpretation=str(event_type),
-+ manifestation=str(manifest),
- actor="application://rhythmbox.desktop",
- subjects=[subject,]
- )
-@@ -150,9 +150,9 @@ class ZeitgeistPlugin(GObject.Object, Peas.Activatable):
- f.query_info_async(Gio.FILE_ATTRIBUTE_STANDARD_CONTENT_TYPE, Gio.FileQueryInfoFlags.NONE, GLib.PRIORITY_DEFAULT, None, file_info_complete, None)
-
- def do_deactivate(self):
-- print "Deactivating Zeitgeist plugin..."
-+ print("Deactivating Zeitgeist plugin...")
- if IFACE is not None:
-- shell = self.object
-+ shell = self.object
- shell_player = shell.props.shell_player
- shell_player.disconnect(self.__psc_id)
- self.__psc_id = None
---
-1.8.1.5
-
diff --git a/media-sound/rhythmbox/rhythmbox-3.0-r1.ebuild b/media-sound/rhythmbox/rhythmbox-3.0-r1.ebuild
deleted file mode 100644
index 4479dbcf1b9b..000000000000
--- a/media-sound/rhythmbox/rhythmbox-3.0-r1.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-3.0-r1.ebuild,v 1.3 2013/09/22 12:04:14 pacho Exp $
-
-EAPI="5"
-GNOME2_LA_PUNT="yes"
-GCONF_DEBUG="no"
-PYTHON_COMPAT=( python3_2 )
-PYTHON_REQ_USE="xml"
-
-inherit eutils gnome2 python-single-r1 multilib virtualx
-
-DESCRIPTION="Music management and playback software for GNOME"
-HOMEPAGE="http://www.rhythmbox.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="cdr daap dbus +libsecret html ipod libnotify lirc mtp nsplugin +python
-test +udev upnp-av visualizer webkit zeitgeist"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-REQUIRED_USE="
- ipod? ( udev )
- mtp? ( udev )
- dbus? ( python )
- webkit? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-# FIXME: double check what to do with fm-radio plugin
-# webkit-gtk-1.10 is needed because it uses gstreamer-1.0
-#
-# To add support for libdmapsharing-2.9.19, use commit 92d75eaa from git
-COMMON_DEPEND="
- >=dev-libs/glib-2.34.0:2
- >=dev-libs/libxml2-2.7.8:2
- >=x11-libs/gtk+-3.6:3[introspection]
- >=x11-libs/gdk-pixbuf-2.18.0:2
- >=dev-libs/gobject-introspection-0.10.0
- >=dev-libs/libpeas-0.7.3[gtk,python?]
- >=dev-libs/totem-pl-parser-3.2.0
- >=net-libs/libsoup-2.26:2.4
- >=net-libs/libsoup-gnome-2.26:2.4
- media-libs/gst-plugins-base:1.0[introspection]
- media-libs/gstreamer:1.0[introspection]
- >=sys-libs/tdb-1.2.6
- dev-libs/json-glib
-
- visualizer? (
- >=media-libs/clutter-1.8:1.0
- >=media-libs/clutter-gst-1.9.92:2.0
- >=media-libs/clutter-gtk-1.0:1.0
- >=x11-libs/mx-1.0.1:1.0
- media-plugins/gst-plugins-libvisual:1.0 )
- cdr? ( >=app-cdr/brasero-2.91.90 )
- daap? (
- >=net-libs/libdmapsharing-2.9.16:3.0
- <net-libs/libdmapsharing-2.9.19:3.0
- media-plugins/gst-plugins-soup:1.0 )
- libsecret? ( >=app-crypt/libsecret-0.14 )
- html? ( >=net-libs/webkit-gtk-1.10:3 )
- libnotify? ( >=x11-libs/libnotify-0.7.0 )
- lirc? ( app-misc/lirc )
- python? ( >=dev-python/pygobject-3.0:3[${PYTHON_USEDEP}] )
- udev? (
- virtual/udev[gudev]
- ipod? ( >=media-libs/libgpod-0.7.92[udev] )
- mtp? ( >=media-libs/libmtp-0.3 ) )
- zeitgeist? ( gnome-extra/zeitgeist )
-"
-RDEPEND="${COMMON_DEPEND}
- media-plugins/gst-plugins-soup:1.0
- media-plugins/gst-plugins-libmms:1.0
- || (
- media-plugins/gst-plugins-cdparanoia:1.0
- media-plugins/gst-plugins-cdio:1.0 )
- media-plugins/gst-plugins-meta:1.0
- media-plugins/gst-plugins-taglib:1.0
- x11-themes/gnome-icon-theme-symbolic
- upnp-av? (
- >=media-libs/grilo-0.2:0.2
- >=media-plugins/grilo-plugins-0.2:0.2[upnp-av] )
- python? (
- x11-libs/gdk-pixbuf:2[introspection]
- x11-libs/gtk+:3[introspection]
- x11-libs/pango[introspection]
-
- dbus? ( sys-apps/dbus )
- libsecret? ( >=app-crypt/libsecret-0.14[introspection] )
- webkit? (
- dev-python/mako[${PYTHON_USEDEP}]
- >=net-libs/webkit-gtk-1.10:3[introspection] ) )
-"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- app-text/yelp-tools
- dev-util/gtk-doc-am
- >=dev-util/intltool-0.35
- >=app-text/gnome-doc-utils-0.9.1
- test? ( dev-libs/check )
-"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- DOCS="AUTHORS ChangeLog DOCUMENTERS INTERNALS \
- MAINTAINERS MAINTAINERS.old NEWS README THANKS"
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=706470
- # In git, remove for bump
- epatch "${FILESDIR}/${P}-gdbus-return-value.patch"
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=708044
- epatch "${FILESDIR}/${P}-rbzeitgeist-python3.patch"
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=708476
- epatch "${FILESDIR}/${PN}-3.0-daap-schema.patch"
-
- rm -v lib/rb-marshal.{c,h} || die
- gnome2_src_prepare
-}
-
-src_configure() {
- # FIXME: bug???
- export GST_INSPECT=/bin/true
-
- # --enable-vala just installs the sample vala plugin, and the configure
- # checks are broken, so don't enable it
- gnome2_src_configure \
- MOZILLA_PLUGINDIR=/usr/$(get_libdir)/nsbrowser/plugins \
- VALAC=$(type -P valac-0.14) \
- --enable-mmkeys \
- --disable-more-warnings \
- --disable-static \
- --disable-vala \
- --without-hal \
- $(use_enable visualizer) \
- $(use_enable daap) \
- $(use_enable libnotify) \
- $(use_enable lirc) \
- $(use_enable nsplugin browser-plugin) \
- $(use_enable python) \
- $(use_enable upnp-av grilo) \
- $(use_with cdr brasero) \
- $(use_with html webkit) \
- $(use_with ipod) \
- $(use_with libsecret) \
- $(use_with mtp) \
- $(use_with udev gudev)
-}
-
-src_test() {
- unset SESSION_MANAGER
- unset DBUS_SESSION_BUS_ADDRESS
- Xemake check || die "test failed"
-}
diff --git a/media-sound/rhythmbox/rhythmbox-3.0.1.ebuild b/media-sound/rhythmbox/rhythmbox-3.0.1.ebuild
index 7ed2e458ec65..9a4ded6ab8a4 100644
--- a/media-sound/rhythmbox/rhythmbox-3.0.1.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-3.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-3.0.1.ebuild,v 1.1 2013/10/15 19:22:33 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-3.0.1.ebuild,v 1.2 2013/10/19 13:57:13 pacho Exp $
EAPI="5"
GNOME2_LA_PUNT="yes"
@@ -17,6 +17,11 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="cdr daap dbus +libsecret html ipod libnotify lirc mtp nsplugin +python
test +udev upnp-av visualizer webkit zeitgeist"
+
+# Let people emerge this by default, bug #472932, reconsider when it starts
+# to support another implementation
+IUSE+=" +python_single_target_python3_2"
+
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
REQUIRED_USE="