summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qtractor/ChangeLog9
-rw-r--r--media-sound/qtractor/qtractor-0.5.12.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/media-sound/qtractor/ChangeLog b/media-sound/qtractor/ChangeLog
index 93577af2e818..da9c3a708a43 100644
--- a/media-sound/qtractor/ChangeLog
+++ b/media-sound/qtractor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qtractor
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qtractor/ChangeLog,v 1.53 2013/07/25 11:53:15 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtractor/ChangeLog,v 1.54 2014/01/18 12:51:20 aballier Exp $
+
+*qtractor-0.5.12 (18 Jan 2014)
+
+ 18 Jan 2014; Alexis Ballier <aballier@gentoo.org> +qtractor-0.5.12.ebuild:
+ version bump
*qtractor-0.5.10 (25 Jul 2013)
diff --git a/media-sound/qtractor/qtractor-0.5.12.ebuild b/media-sound/qtractor/qtractor-0.5.12.ebuild
new file mode 100644
index 000000000000..2b24be487a43
--- /dev/null
+++ b/media-sound/qtractor/qtractor-0.5.12.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtractor/qtractor-0.5.12.ebuild,v 1.1 2014/01/18 12:51:20 aballier Exp $
+
+EAPI=2
+
+inherit qt4-r2 flag-o-matic
+
+DESCRIPTION="Qtractor is an Audio/MIDI multi-track sequencer."
+HOMEPAGE="http://qtractor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qtractor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug dssi libsamplerate mad osc rubberband vorbis sse zlib"
+
+RDEPEND=">=dev-qt/qtcore-4.2:4
+ >=dev-qt/qtgui-4.7:4
+ media-libs/alsa-lib
+ media-libs/libsndfile
+ media-sound/jack-audio-connection-kit
+ media-libs/ladspa-sdk
+ media-libs/lilv
+ media-libs/lv2
+ media-libs/suil
+ dssi? ( media-libs/dssi )
+ mad? ( media-libs/libmad )
+ libsamplerate? ( media-libs/libsamplerate )
+ osc? ( media-libs/liblo )
+ rubberband? ( media-libs/rubberband )
+ vorbis? ( media-libs/libvorbis )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README ChangeLog TODO AUTHORS"
+
+src_configure() {
+ econf \
+ $(use_enable mad libmad) \
+ $(use_enable libsamplerate) \
+ $(use_enable vorbis libvorbis) \
+ $(use_enable osc liblo) \
+ --enable-ladspa \
+ $(use_enable dssi) \
+ --enable-lilv \
+ $(use_enable rubberband librubberband) \
+ $(use_enable sse) \
+ $(use_enable zlib libz) \
+ $(use_enable debug)
+ eqmake4 qtractor.pro -o qtractor.mak
+}