summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/csound/ChangeLog8
-rw-r--r--media-sound/csound/csound-5.16.6-r1.ebuild (renamed from media-sound/csound/csound-5.16.6.ebuild)2
-rw-r--r--media-sound/csound/files/csound-5.16.6-install.patch41
3 files changed, 38 insertions, 13 deletions
diff --git a/media-sound/csound/ChangeLog b/media-sound/csound/ChangeLog
index 0a87ecfbc5c1..a908dd46e459 100644
--- a/media-sound/csound/ChangeLog
+++ b/media-sound/csound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/csound
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/ChangeLog,v 1.3 2012/02/27 07:03:24 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/ChangeLog,v 1.4 2012/02/27 13:37:56 radhermit Exp $
+
+*csound-5.16.6-r1 (27 Feb 2012)
+
+ 27 Feb 2012; Tim Harder <radhermit@gentoo.org> -csound-5.16.6.ebuild,
+ +csound-5.16.6-r1.ebuild, files/csound-5.16.6-install.patch:
+ Revbump to properly install all required headers. Remove old.
27 Feb 2012; Tim Harder <radhermit@gentoo.org> csound-5.16.6.ebuild:
Only install locales when nls is enabled.
diff --git a/media-sound/csound/csound-5.16.6.ebuild b/media-sound/csound/csound-5.16.6-r1.ebuild
index 731763610409..77404e010b5a 100644
--- a/media-sound/csound/csound-5.16.6.ebuild
+++ b/media-sound/csound/csound-5.16.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/csound-5.16.6.ebuild,v 1.2 2012/02/27 07:03:24 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/csound-5.16.6-r1.ebuild,v 1.1 2012/02/27 13:37:56 radhermit Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
diff --git a/media-sound/csound/files/csound-5.16.6-install.patch b/media-sound/csound/files/csound-5.16.6-install.patch
index 09b6e0d99391..e715f58dedd7 100644
--- a/media-sound/csound/files/csound-5.16.6-install.patch
+++ b/media-sound/csound/files/csound-5.16.6-install.patch
@@ -66,7 +66,7 @@
if err == 0:
if i[:13] == 'libcsound.so.':
err = installLink(i, concatPath([libDir, 'libcsound.so']))
-@@ -292,7 +267,7 @@
+@@ -292,11 +267,26 @@
if i in pluginList:
pluginList.remove(i)
for i in pluginList:
@@ -75,7 +75,26 @@
installErrors = installErrors or err
# copy header files
-@@ -313,6 +288,7 @@
+
++# Add forgotten header dependencies
++headerdeps = []
++for header in headerFiles:
++ f = open(header)
++ for line in f:
++ m = re.findall('^#include "\w+.\w+"', line)
++ if m:
++ n = re.match('^#include "(.+)"', "".join(m))
++ if os.path.isfile("H/" + n.group(1)):
++ headerdeps.append("H/" + n.group(1))
++ else:
++ headerdeps.append("interfaces/" + n.group(1))
++ f.close()
++headerFiles = list(set(headerdeps + headerFiles))
++
+ print ' === Installing header files ==='
+ err = installFiles(headerFiles, includeDir)
+ installErrors = installErrors or err
+@@ -313,6 +303,7 @@
['_loris\\.so', '1', pythonDir2],
['_scoregen\\.so', '1', pythonDir2],
['_CsoundAC\\.so ', '1', pythonDir2],
@@ -83,13 +102,14 @@
['csnd\\.jar', '0', javaDir],
['interfaces/csound5\\.lisp', '0', lispDir]]
for i in wrapperList:
-@@ -322,48 +298,21 @@
+@@ -322,48 +313,21 @@
if i[1] == '0':
err = installFile(fName, i[2])
else:
- err = installXFile('--strip-debug', fName, i[2])
-- installErrors = installErrors or err
--
++ err = installXFile('', fName, i[2])
+ installErrors = installErrors or err
+
-# copy XMG files
-
-print ' === Installing Localisation files ==='
@@ -109,9 +129,8 @@
- print ' %s' % fileName
- else:
- print ' *** error copying %s' % fileName
-+ err = installXFile('', fName, i[2])
- installErrors = installErrors or err
-
+- installErrors = installErrors or err
+-
-# Copy documentation
-
-print ' === Installing documentation ==='
@@ -138,7 +157,7 @@
# copy STK raw wave files
-@@ -398,7 +347,7 @@
+@@ -398,7 +362,7 @@
pdDir = ''
if pdDir != '':
print ' === Installing csoundapi~ PD object ==='
@@ -147,7 +166,7 @@
if err == 0:
try:
os.chmod(concatPath([instDir, pdDir, 'csoundapi~.pd_linux']), 0644)
-@@ -420,42 +369,6 @@
+@@ -420,42 +384,6 @@
'%s/%s' % (vimDir, 'syntax'))
installErrors = installErrors or err
@@ -190,7 +209,7 @@
# -----------------------------------------------------------------------------
-@@ -481,10 +394,6 @@
+@@ -481,10 +409,6 @@
print ' CSSTRNGS=%s' % xmgDir
if '%s/libstk.so' % pluginDir in fileList:
print ' RAWWAVE_PATH=%s' % rawWaveDir