summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ChangeLog7
-rw-r--r--media-video/ffmpeg/Manifest6
-rw-r--r--media-video/ffmpeg/ffmpeg-0.4.8.20040222.ebuild102
-rw-r--r--media-video/ffmpeg/files/digest-ffmpeg-0.4.8.200402221
4 files changed, 113 insertions, 3 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index a428643b293e..cfcc5d413cfb 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ffmpeg
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.26 2004/02/17 21:25:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.27 2004/03/11 21:35:07 kanaka Exp $
+
+*ffmpeg-0.4.8.20040222 (11 Mar 2004)
+
+ 11 Mar 2004; <joelm@gentoo.org> ffmpeg-0.4.8.20040222.ebuild:
+ Install libpostproc library. Update to newer snapshot. Bug 27051
17 Feb 2004; Aron Griffis <agriffis@gentoo.org> ffmpeg-0.4.8.ebuild:
stable on alpha and ia64
diff --git a/media-video/ffmpeg/Manifest b/media-video/ffmpeg/Manifest
index dbcaa653a25e..abcb94e9af59 100644
--- a/media-video/ffmpeg/Manifest
+++ b/media-video/ffmpeg/Manifest
@@ -1,8 +1,10 @@
+MD5 80efd3681d7f51fdddffaf187e525f82 ffmpeg-0.4.8.20040222.ebuild 3188
+MD5 c47ffd4762bbd81606974cc39a507a87 ffmpeg-0.4.8.ebuild 2387
+MD5 f08417b78b86be6de292fd739077ef67 ffmpeg-0.4.7.ebuild 2182
MD5 d21381cbd4ea1b3345eb37d9499e7dfd ChangeLog 4306
MD5 7300a7b361fa9f48e37722c6952bd432 metadata.xml 158
-MD5 f08417b78b86be6de292fd739077ef67 ffmpeg-0.4.7.ebuild 2182
-MD5 c47ffd4762bbd81606974cc39a507a87 ffmpeg-0.4.8.ebuild 2387
MD5 6f1d9c82b5e8c3b7c46b80bc3c1bb443 files/alpha-idct.patch 777
MD5 77014ea836fa26b88ebae7c85c912059 files/ffmpeg-0.4.7-2.6.patch 491
MD5 7eca667f050b6c515830ff9be05bacc6 files/digest-ffmpeg-0.4.7 65
MD5 0a76b7a4442aea90d56ac85508b2eff5 files/digest-ffmpeg-0.4.8 65
+MD5 56615d0a04f7435f464f01f8bed50c50 files/digest-ffmpeg-0.4.8.20040222 69
diff --git a/media-video/ffmpeg/ffmpeg-0.4.8.20040222.ebuild b/media-video/ffmpeg/ffmpeg-0.4.8.20040222.ebuild
new file mode 100644
index 000000000000..06db624b9bbc
--- /dev/null
+++ b/media-video/ffmpeg/ffmpeg-0.4.8.20040222.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.8.20040222.ebuild,v 1.1 2004/03/11 21:35:07 kanaka Exp $
+
+inherit eutils flag-o-matic
+
+# TODO: --enablea52bin breaks compile
+
+DESCRIPTION="Complete solution to record, convert and stream audio and video. Includes libavcodec."
+HOMEPAGE="http://ffmpeg.sourceforge.net/"
+PDATE=${PV##*.}
+MY_PV=${PV%.*}
+S=${WORKDIR}/${PN}-${PDATE}
+SRC_URI="http://download.videolan.org/pub/videolan/vlc/0.7.1/contrib/ffmpeg-${PDATE}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ia64"
+IUSE="mmx altivec encode oggvorbis doc faad dvd static sdl imlib truetype"
+
+DEPEND="encode? ( >=media-sound/lame-3.92 )
+ oggvorbis? ( >=media-libs/libvorbis-1.0-r1 )
+ doc? ( >=app-text/texi2html-1.64 )
+ faad? ( >=media-libs/faad2-1.1 )
+ dvd? ( >=media-libs/a52dec-0.7.4 )
+ sdl? ( >=media-libs/libsdl-1.2.5 )
+ imlib? ( >=media-libs/imlib2-1.0.6 )
+ truetype? ( >=media-libs/freetype-2.1.2 )
+ !<media-video/mplayer-1.0_pre3-r1"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S}
+
+ # for some reason it tries to #include <X11/Xlib.h>,b ut doesn't use it
+ cd ${S}
+ sed -i s:\#define\ HAVE_X11:\#define\ HAVE_LINUX: ffplay.c
+}
+
+src_compile() {
+ filter-flags -fforce-addr -fPIC
+ # fixes bug #16281
+ use alpha && append-flags -fPIC
+ use amd64 && append-flags -fPIC
+
+ local myconf
+ #myconf="${myconf} --disable-opts --enable-pp --enable-shared-pp"
+ myconf="${myconf} --disable-opts --enable-pp"
+ use mmx || myconf="${myconf} --disable-mmx"
+ use encode && myconf="${myconf} --enable-mp3lame"
+ use oggvorbis && myconf="${myconf} --enable-vorbis"
+ use faad && myconf="${myconf} --enable-faad --enable-faadbin"
+ use dvd && myconf="${myconf} --enable-a52"
+ use static || myconf="${myconf} --enable-shared"
+ use sdl || myconf="${myconf} --disable-ffplay"
+ use debug || myconf="${myconf} --disable-debug"
+ use altivec || myconf="${myconf} --disable-altivec"
+
+# Using --enable-a52bin breaks the compile
+ #use dvd && myconf="${myconf} --enable-a52 --enable-a52bin"
+
+ ./configure ${myconf} \
+ --prefix=/usr || die "./configure failed."
+ make || die "make failed."
+ use doc && make -C doc all
+
+ # Build libpostproc
+ cd ${S}/libavcodec/libpostproc
+ make || die "Failed to build libpostproc.a!"
+ make SHARED_PP="yes" || die "Failed to build libpostproc.so!"
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ prefix=${D}/usr \
+ bindir=${D}/usr/bin \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+ dosym /usr/bin/ffmpeg /usr/bin/ffplay
+ dosym /usr/lib/libavcodec-${MY_PV}.so /usr/lib/libavcodec.so
+
+ dodoc COPYING CREDITS Changelog INSTALL README
+ docinto doc
+ dodoc doc/TODO doc/*.html doc/*.texi
+ insinto /etc
+ doins doc/ffserver.conf
+
+ # Install libpostproc ...
+ cd ${S}/libavcodec/libpostproc
+ make prefix=${D}/usr \
+ install || die "Failed to install libpostproc.a!"
+ make prefix=${D}/usr \
+ SHARED_PP="yes" \
+ install || die "Failed to install libpostproc.so!"
+ cd ${S}
+ # Some stuff like transcode can use this one.
+ dolib ${S}/libavcodec/libpostproc/libpostproc.a
+
+ preplib /usr
+}
diff --git a/media-video/ffmpeg/files/digest-ffmpeg-0.4.8.20040222 b/media-video/ffmpeg/files/digest-ffmpeg-0.4.8.20040222
new file mode 100644
index 000000000000..67b183c7eacc
--- /dev/null
+++ b/media-video/ffmpeg/files/digest-ffmpeg-0.4.8.20040222
@@ -0,0 +1 @@
+MD5 9d94f58d1c5eda0d11075b1755599530 ffmpeg-20040222.tar.bz2 1256586