summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/libav/libav-11.9999.ebuild')
-rw-r--r--media-video/libav/libav-11.9999.ebuild71
1 files changed, 42 insertions, 29 deletions
diff --git a/media-video/libav/libav-11.9999.ebuild b/media-video/libav/libav-11.9999.ebuild
index 902989e5a36f..a1ec00449aba 100644
--- a/media-video/libav/libav-11.9999.ebuild
+++ b/media-video/libav/libav-11.9999.ebuild
@@ -1,45 +1,49 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-11.9999.ebuild,v 1.4 2015/03/16 10:24:32 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-11.9999.ebuild,v 1.5 2015/03/17 18:55:07 lu_zero Exp $
EAPI=5
+inherit eutils flag-o-matic multilib multilib-minimal toolchain-funcs
+
if [[ ${PV} == *9999 ]] ; then
- SCM="git-2"
: ${EGIT_REPO_URI:="git://git.libav.org/libav.git"}
if [[ ${PV%9999} != "" ]] ; then
: ${EGIT_BRANCH:="release/${PV%.9999}"}
fi
+ inherit git-r3
fi
-inherit eutils flag-o-matic multilib multilib-minimal toolchain-funcs ${SCM}
-
DESCRIPTION="Complete solution to record, convert and stream audio and video"
-HOMEPAGE="http://libav.org/"
+HOMEPAGE="https://libav.org/"
if [[ ${PV} == *9999 ]] ; then
SRC_URI=""
elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
SRC_URI="http://dev.gentoo.org/~lu_zero/libav/${P}.tar.xz"
else # Official release
- SRC_URI="http://${PN}.org/releases/${P}.tar.xz"
+ SRC_URI="https://libav.org/releases/${P}.tar.xz"
fi
-
-SRC_URI+=" test? ( http://dev.gentoo.org/~lu_zero/libav/fate-11.tar.xz )"
+# 9999 does not have fate-*.tar.xz
+[[ ${PV%9999} != "" ]] && SRC_URI+=" test? ( http://dev.gentoo.org/~lu_zero/libav/fate-${PV%%.*}.tar.xz )"
LICENSE="LGPL-2.1 gpl? ( GPL-3 )"
-SLOT="0/10"
+SLOT="0/11"
[[ ${PV} == *9999 ]] || KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64
~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos
~x64-solaris ~x86-solaris"
-IUSE="aac alsa amr +bzip2 cdio cpudetection custom-cflags debug doc +encode
- faac fdk frei0r fontconfig +gpl gsm +hardcoded-tables ieee1394 jack jpeg2k
- mp3 +network openssl opus oss pic pulseaudio rtmp schroedinger sdl speex ssl
- static-libs test theora threads tools truetype v4l vaapi vdpau vorbis vpx X
+IUSE="aac alsa amr bs2b +bzip2 cdio cpudetection custom-cflags debug doc +encode faac fdk
+ frei0r fontconfig +gpl gsm +hardcoded-tables ieee1394 jack jpeg2k mp3
+ +network openssl opus oss pic pulseaudio rtmp schroedinger sdl speex ssl
+ static-libs test theora threads tools truetype twolame v4l vaapi vdpau vorbis vpx X
wavpack webp x264 x265 xvid +zlib"
# String for CPU features in the useflag[:configure_option] form
# if :configure_option isn't set, it will use 'useflag' as configure option
-CPU_FEATURES="cpu_flags_x86_3dnow:amd3dnow cpu_flags_x86_3dnowext:amd3dnowext altivec cpu_flags_x86_avx:avx cpu_flags_x86_mmx:mmx cpu_flags_x86_mmxext:mmxext neon cpu_flags_x86_ssse3:ssse3 vis cpu_flags_x86_avx2:avx2"
+CPU_FEATURES="altivec armv5te armv6 armv6t2 armvfp:vfp neon"
+X86_CPU_FEATURES="3dnow:amd3dnow 3dnowext:amd3dnowext mmx mmxext sse sse2 sse3 ssse3 sse4_1:sse4 sse4_2:sse42 avx xop fma3 fma4 avx2"
+for i in ${X86_CPU_FEATURES} ; do
+ CPU_FEATURES+=" cpu_flags_x86_${i%:*}:${i#*:}"
+done
for i in ${CPU_FEATURES} ; do
IUSE+=" ${i%:*}"
done
@@ -48,23 +52,19 @@ RDEPEND="
!media-video/ffmpeg:0
alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
amr? ( >=media-libs/opencore-amr-0.1.3-r1[${MULTILIB_USEDEP}] )
+ bs2b? ( >=media-libs/libbs2b-3.1.0-r1[${MULTILIB_USEDEP}] )
bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
- cdio? (
- || (
- >=dev-libs/libcdio-paranoia-0.90_p1-r1[${MULTILIB_USEDEP}]
- <dev-libs/libcdio-0.90[-minimal,${MULTILIB_USEDEP}]
- )
- )
+ cdio? ( >=dev-libs/libcdio-paranoia-0.90_p1-r1[${MULTILIB_USEDEP}] )
encode? (
aac? ( >=media-libs/vo-aacenc-0.1.3[${MULTILIB_USEDEP}] )
amr? ( >=media-libs/vo-amrwbenc-0.1.2-r1[${MULTILIB_USEDEP}] )
faac? ( >=media-libs/faac-1.28-r3[${MULTILIB_USEDEP}] )
- fdk? ( >=media-libs/fdk-aac-0.1.2[${MULTILIB_USEDEP}] )
mp3? ( >=media-sound/lame-3.99.5-r1[${MULTILIB_USEDEP}] )
theora? (
>=media-libs/libtheora-1.1.1[encode,${MULTILIB_USEDEP}]
>=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}]
)
+ twolame? ( >=media-sound/twolame-0.3.13-r1[${MULTILIB_USEDEP}] )
vorbis? (
>=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}]
>=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}]
@@ -75,6 +75,7 @@ RDEPEND="
x265? ( >=media-libs/x265-1.2:=[${MULTILIB_USEDEP}] )
xvid? ( >=media-libs/xvid-1.3.2-r1[${MULTILIB_USEDEP}] )
)
+ fdk? ( >=media-libs/fdk-aac-0.1.2[${MULTILIB_USEDEP}] )
frei0r? ( media-plugins/frei0r-plugins )
gsm? ( >=media-sound/gsm-1.0.13-r1[${MULTILIB_USEDEP}] )
ieee1394? (
@@ -129,7 +130,8 @@ RDEPEND="${RDEPEND}
# faac and aac are concurent implementations
# amr and aac require at least lgpl3
# x264 requires gpl2
-REQUIRED_USE="rtmp? ( network )
+REQUIRED_USE="
+ rtmp? ( network )
amr? ( gpl ) aac? ( gpl ) x264? ( gpl ) X? ( gpl ) cdio? ( gpl ) x265? ( gpl )
test? ( encode zlib )
fontconfig? ( truetype )
@@ -140,6 +142,12 @@ MULTILIB_WRAPPED_HEADERS=(
/usr/include/libavutil/avconfig.h
)
+src_unpack() {
+ [[ ${PV} == *9999 ]] && git-r3_src_unpack
+ # 9999 does not have fate-*.tar.xz
+ [[ ${PV%9999} != "" ]] && default_src_unpack
+}
+
src_prepare() {
epatch_user
@@ -158,6 +166,9 @@ multilib_src_configure() {
local myconf=( ${EXTRA_LIBAV_CONF} )
local uses i
+ # 9999 does not have fate-*.tar.xz
+ [[ ${PV%9999} != "" ]] && use test && myconf+=( --samples="${WORKDIR}/fate" )
+
myconf+=(
$(use_enable gpl)
$(use_enable gpl version3)
@@ -187,11 +198,10 @@ multilib_src_configure() {
# Encoders
if use encode; then
use faac && myconf+=( --enable-nonfree )
- use fdk && myconf+=( --enable-nonfree --enable-libfdk-aac )
use mp3 && myconf+=( --enable-libmp3lame )
use amr && myconf+=( --enable-libvo-amrwbenc )
use aac && myconf+=( --enable-libvo-aacenc )
- uses="faac theora vorbis wavpack webp x264 x265 xvid"
+ uses="faac theora twolame vorbis wavpack webp x264 x265 xvid"
for i in ${uses}; do
use ${i} && myconf+=( --enable-lib${i} )
done
@@ -217,6 +227,7 @@ multilib_src_configure() {
use ${i} || myconf+=( --disable-outdev=${i} )
done
# libavfilter options
+ use bs2b && myconf+=( --enable-libbs2b )
multilib_is_native_abi && use frei0r && myconf+=( --enable-frei0r )
use truetype && myconf+=( --enable-libfreetype )
use fontconfig && myconf+=( --enable-libfontconfig )
@@ -226,6 +237,7 @@ multilib_src_configure() {
# Decoders
use amr && myconf+=( --enable-libopencore-amrwb --enable-libopencore-amrnb )
+ use fdk && myconf+=( --enable-nonfree --enable-libfdk-aac )
uses="gsm opus rtmp schroedinger speex vpx"
for i in ${uses}; do
use ${i} && myconf+=( --enable-lib${i} )
@@ -238,7 +250,7 @@ multilib_src_configure() {
done
# pass the right -mfpu as extra
- use neon && myconf+=( --extra-cflags=-mfpu=neon )
+ use neon && append-cflags -mfpu=neon
# disable mmx accelerated code if PIC is required
# as the provided asm decidedly is not PIC for x86.
@@ -320,10 +332,11 @@ multilib_src_install() {
}
multilib_src_install_all() {
- dodoc Changelog README INSTALL
+ dodoc Changelog README.md INSTALL
}
multilib_src_test() {
- LD_LIBRARY_PATH="${BUILD_DIR}/libswscale:${BUILD_DIR}/libavcodec:${BUILD_DIR}/libavdevice:${BUILD_DIR}/libavfilter:${BUILD_DIR}/libavformat:${BUILD_DIR}/libavresample:${BUILD_DIR}/libavutil" \
- emake -j1 fate
-}
+ local _libs="$(for i in lib*/;do echo -n "${BUILD_DIR}/${i%/}:";done)"
+ einfo "LD_LIBRARY_PATH is set to \"${_libs}\""
+ LD_LIBRARY_PATH="${_libs}" emake -k -j1 fate
+} \ No newline at end of file